blob: 024ccaefce909f4bd3c95ef71f2f1c7355decbaa [file] [log] [blame]
George Hung38305142020-09-25 07:55:30 +08001SUMMARY = "Phosphor BMC Memory ECC Logging"
2DESCRIPTION = "Daemon to monitor and report the BMC memory ECC"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5PR = "r1"
6
7inherit meson pkgconfig
8inherit systemd
9
10DEPENDS += "sdbusplus"
11DEPENDS += "phosphor-dbus-interfaces"
12DEPENDS += "sdeventplus"
13DEPENDS += "phosphor-logging"
14
15RDEPENDS_${PN} += "phosphor-sel-logger"
16
17SRC_URI = "git://github.com/openbmc/phosphor-ecc.git"
18SRCREV = "a1d42027be51ac94b1b14b59f05797287e57d5b4"
19
20S = "${WORKDIR}/git"
21
22SYSTEMD_SERVICE_${PN} = " ${PN}.service"