blob: 9033632150fb6da59bd20b2c5899073c049dd3d4 [file] [log] [blame]
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +08001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2
3inherit obmc-phosphor-systemd systemd
4
5SRC_URI += "file://yosemite4-phosphor-multi-gpio-monitor.json \
Chris Wang0598b572024-03-12 17:29:15 +08006 file://configure-nic-mctp-endpoint.sh \
7 file://setup-nic-endpoint-slot@.service \
8 file://remove-nic-endpoint-slot@.service \
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +08009 file://set-button-sled.service \
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080010 file://probe-slot-device@.service \
11 file://probe-slot-device \
Delphine CC Chiu085d6192023-11-24 16:02:08 +080012 file://rescan-fru-device@.service \
13 file://rescan-fru-device \
Delphine CC Chiu2f1f94c2024-01-12 17:22:20 +080014 file://slot-hot-plug@.service \
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080015 "
16
Patrick Williamsa2fb20c2024-02-05 14:11:29 -060017RDEPENDS:${PN}:append = " bash"
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080018
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080019FILES:${PN} += "${systemd_system_unitdir}/*"
20
21SYSTEMD_SERVICE:${PN} += " \
22 set-button-sled.service \
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080023 probe-slot-device@.service \
Delphine CC Chiu085d6192023-11-24 16:02:08 +080024 rescan-fru-device@.service \
Delphine CC Chiu2f1f94c2024-01-12 17:22:20 +080025 slot-hot-plug@.service \
Chris Wang0598b572024-03-12 17:29:15 +080026 setup-nic-endpoint-slot@.service \
27 remove-nic-endpoint-slot@.service \
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080028 "
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080029
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080030SYSTEMD_AUTO_ENABLE = "enable"
31
32do_install:append:() {
33 install -d ${D}${datadir}/phosphor-gpio-monitor
34 install -m 0644 ${WORKDIR}/yosemite4-phosphor-multi-gpio-monitor.json \
35 ${D}${datadir}/phosphor-gpio-monitor/phosphor-multi-gpio-monitor.json
36 install -m 0644 ${WORKDIR}/set-button-sled.service ${D}${systemd_system_unitdir}/set-button-sled.service
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080037 install -m 0644 ${WORKDIR}/probe-slot-device@.service ${D}${systemd_system_unitdir}/probe-slot-device@.service
Delphine CC Chiu085d6192023-11-24 16:02:08 +080038 install -m 0644 ${WORKDIR}/rescan-fru-device@.service ${D}${systemd_system_unitdir}/rescan-fru-device@.service
Delphine CC Chiu2f1f94c2024-01-12 17:22:20 +080039 install -m 0644 ${WORKDIR}/slot-hot-plug@.service ${D}${systemd_system_unitdir}/slot-hot-plug@.service
Chris Wang0598b572024-03-12 17:29:15 +080040 install -m 0644 ${WORKDIR}/setup-nic-endpoint-slot@.service ${D}${systemd_system_unitdir}/
41 install -m 0644 ${WORKDIR}/remove-nic-endpoint-slot@.service ${D}${systemd_system_unitdir}/
Delphine CC Chiu6e311d32023-11-15 15:40:58 +080042 install -d ${D}${libexecdir}/${PN}
Patrick Williamsd3135242024-01-19 16:45:58 -060043 install -m 0755 ${WORKDIR}/probe-slot-device ${D}${libexecdir}/${PN}/
44 install -m 0755 ${WORKDIR}/rescan-fru-device ${D}${libexecdir}/${PN}/
Chris Wang0598b572024-03-12 17:29:15 +080045 install -d ${D}/${bindir}
46 install -m 0755 ${WORKDIR}/configure-nic-mctp-endpoint.sh ${D}/${bindir}/
Delphine CC Chiu9d5d2482023-10-18 18:39:21 +080047}