Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "A ``pytest`` fixture for benchmarking code. It will group the tests into rounds that are calibrated to the chosen timer." |
| 5 | HOMEPAGE = "https://github.com/ionelmc/pytest-benchmark" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9c5c2c74370826468065c5702b8a1fcf" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "40e263f912de5a81d891619032983557d62a3d85843f9a9f30b98baea0cd7b47" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | RDEPENDS:${PN} += "python3-core python3-py-cpuinfo python3-pytest python3-aspectlib" |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |