Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Set of i2c tools for linux" |
| 2 | HOMEPAGE = "https://i2c.wiki.kernel.org/index.php/I2C_Tools" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | DESCRIPTION = "The i2c-tools package contains a heterogeneous set of I2C tools for Linux: a bus probing tool, a chip dumper, register-level SMBus access helpers, EEPROM decoding scripts, EEPROM programming tools, and a python module for SMBus access. All versions of Linux are supported, as long as I2C support is included in the kernel." |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 4 | SECTION = "base" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 7 | |
| 8 | SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/${BP}.tar.gz \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 9 | " |
| 10 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "eec464e42301d93586cbeca3845ed61bff40f560670e5b35baec57301d438148" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | inherit update-alternatives |
| 14 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 15 | EXTRA_OEMAKE = "bindir=${bindir} sbindir=${sbindir} \ |
| 16 | incdir=${includedir} libdir=${libdir} \ |
| 17 | mandir=${mandir} \ |
| 18 | EXTRA=eeprog" |
| 19 | |
| 20 | do_install() { |
| 21 | oe_runmake 'DESTDIR=${D}' install |
| 22 | } |
| 23 | |
| 24 | PACKAGES =+ "${PN}-misc" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | FILES:${PN}-misc = "${sbindir}/i2c-stub-from-dump \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 26 | ${bindir}/ddcmon \ |
| 27 | ${bindir}/decode-edid \ |
| 28 | ${bindir}/decode-dimms \ |
| 29 | ${bindir}/decode-vaio \ |
| 30 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | RDEPENDS:${PN}-misc = "${PN} perl perl-module-posix \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 32 | perl-module-constant perl-module-file-basename \ |
| 33 | perl-module-fcntl perl-module-strict perl-module-vars \ |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 34 | perl-module-carp \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 35 | " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 36 | |
| 37 | ALTERNATIVE_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | ALTERNATIVE:${PN} = "i2cdetect i2cdump i2cget i2cset i2ctransfer" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 39 | ALTERNATIVE_LINK_NAME[i2cdetect] = "${sbindir}/i2cdetect" |
| 40 | ALTERNATIVE_LINK_NAME[i2cdump] = "${sbindir}/i2cdump" |
| 41 | ALTERNATIVE_LINK_NAME[i2cget] = "${sbindir}/i2cget" |
| 42 | ALTERNATIVE_LINK_NAME[i2cset] = "${sbindir}/i2cset" |
Brad Bishop | 96ff198 | 2019-08-19 13:50:42 -0400 | [diff] [blame] | 43 | ALTERNATIVE_LINK_NAME[i2ctransfer] = "${sbindir}/i2ctransfer" |