blob: 40b6355f4b7f4e7acc5148a0bff5bb90683fb480 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Poetry PEP 517 Build Backend"
2DESCRIPTION = "Poetry PEP 517 Build Backend"
3HOMEPAGE = "https://github.com/python-poetry/poetry-core"
4BUGTRACKER = "https://github.com/python-poetry/poetry-core"
5CHANGELOG = "https://github.com/python-poetry/poetry-core/blob/master/CHANGELOG.md"
6
7LICENSE = "Apache-2.0 & BSD-2-Clause & MIT"
8LIC_FILES_CHKSUM = "\
9 file://LICENSE;md5=78c39cfd009863ae44237a7ab1f9cedc \
10 file://src/poetry/core/_vendor/attr/_version_info.py;beginline=1;endline=1;md5=b2dccaa94b3629a08bfb4f983cad6f89 \
11 file://src/poetry/core/_vendor/attrs/LICENSE;md5=5e55731824cf9205cfabeab9a0600887 \
12 file://src/poetry/core/_vendor/jsonschema/COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
13 file://src/poetry/core/_vendor/lark/LICENSE;md5=fcfbf1e2ecc0f37acbb5871aa0267500 \
14 file://src/poetry/core/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
15 file://src/poetry/core/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
16 file://src/poetry/core/_vendor/packaging/LICENSE.BSD;md5=7bef9bf4a8e4263634d0597e7ba100b8 \
Andrew Geissler517393d2023-01-13 08:55:19 -060017 file://src/poetry/core/_vendor/pyrsistent/LICENSE.mit;md5=b695eb9c6e7a6fb1b1bc2d193c42776e \
Patrick Williamsb542dec2023-06-09 01:26:37 -050018 file://src/poetry/core/_vendor/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \
Andrew Geissler517393d2023-01-13 08:55:19 -060019"
20
Andrew Geissler5082cc72023-09-11 08:41:39 -040021SRC_URI[sha256sum] = "8f679b83bd9c820082637beca1204124d5d2a786e4818da47ec8acefd0353b74"
Andrew Geissler517393d2023-01-13 08:55:19 -060022
23inherit python_poetry_core pypi
24PYPI_ARCHIVE_NAME = "poetry_core-${PV}.${PYPI_PACKAGE_EXT}"
25S = "${WORKDIR}/poetry_core-${PV}"
26
Andrew Geissler517393d2023-01-13 08:55:19 -060027RDEPENDS:${PN}:append:class-target = "\
28 python3-compression \
29 python3-core \
30 python3-crypt \
31 python3-io \
32 python3-json \
33 python3-logging \
34 python3-netclient \
35 python3-pathlib2 \
36 python3-pprint \
37 python3-shell \
38"
39
40RDEPENDS:${PN} += "\
41 python3-pip \
42 python3-six \
43"
44
45BBCLASSEXTEND = "native nativesdk"