Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Python bindings for the DBus inter-process communication system" |
| 2 | SECTION = "devel/python" |
| 3 | HOMEPAGE = "http://www.freedesktop.org/Software/dbus" |
| 4 | LICENSE = "MIT & AFL-2.1 | GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \ |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 6 | file://dbus-gmain/COPYING;md5=99fece6728a80737c8fd3e7c734c17c4 " |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native" |
| 8 | |
| 9 | SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \ |
| 10 | " |
| 11 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 12 | SRC_URI[md5sum] = "c8739234fca9fba26368d1a337abe830" |
| 13 | SRC_URI[sha256sum] = "b10206ba3dd641e4e46411ab91471c88e0eec1749860e4285193ee68df84ac31" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | S = "${WORKDIR}/dbus-python-${PV}" |
| 15 | |
| 16 | inherit distutils-base autotools pkgconfig |
| 17 | |
| 18 | # documentation needs python-sphinx, which is not in oe-core or meta-python for now |
| 19 | # change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python |
| 20 | EXTRA_OECONF += "--disable-documentation" |
| 21 | |
| 22 | export STAGING_LIBDIR |
| 23 | export STAGING_INCDIR |
| 24 | |
| 25 | RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml" |
| 26 | |
| 27 | FILES_${PN}-dev += "${libdir}/pkgconfig" |
| 28 | |
| 29 | do_install_append() { |
| 30 | # Remove files that clash with python3-dbus; their content is same |
| 31 | rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc |
| 32 | } |