blob: 6903053b5bbe2126e12013c27771a86637837166 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Generates traces of I/O traffic on block devices"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05002HOMEPAGE = "http://brick.kernel.dk/snaps/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
5
6DEPENDS = "libaio"
7
Brad Bishop316dfdd2018-06-25 12:45:53 -04008SRCREV = "cca113f2fe0759b91fd6a0e10fdcda2c28f18a7e"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009
Brad Bishop316dfdd2018-06-25 12:45:53 -040010PV = "1.2.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
12SRC_URI = "git://git.kernel.dk/blktrace.git \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050013 file://ldflags.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080014 file://CVE-2018-10689.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://make-btt-scripts-python3-ready.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050016"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050017
18S = "${WORKDIR}/git"
19
20EXTRA_OEMAKE = "\
21 'CC=${CC}' \
22 'CFLAGS=${CFLAGS}' \
23 'LDFLAGS=${LDFLAGS}' \
24"
25
26# There are a few parallel issues:
27# 1) ../rbtree.o: error adding symbols: Invalid operation
28# collect2: error: ld returned 1 exit status
29# Makefile:42: recipe for target 'btt' failed
30# 2) git/blkiomon.c:216: undefined reference to `rb_insert_color'
31# collect2: error: ld returned 1 exit status
32# Makefile:27: recipe for target 'blkparse' failed
33# 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab'
34# 4) btreplay.o: file not recognized: File truncated
35# collect2: error: ld returned 1 exit status
36# btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory
37PARALLEL_MAKE = ""
38
39do_install() {
40 oe_runmake ARCH="${ARCH}" prefix=${prefix} \
41 mandir=${mandir} DESTDIR=${D} install
42}
43