blob: 9c22cb7408120023f4ceaea10b15caa2f79bf58c [file] [log] [blame]
Jason M. Bills267243e2018-10-05 09:17:31 -07001SUMMARY = "Intel OEM IPMI commands"
2DESCRIPTION = "Intel OEM IPMI commands"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a6a4edad4aed50f39a66d098d74b265b"
6
7SRC_URI = "git://github.com/openbmc/intel-ipmi-oem"
Andrew Geissler4a453f12018-11-20 00:40:20 +00008SRCREV = "703922d0eac8963adce747805e45eeb7845b3d5f"
Jason M. Bills267243e2018-10-05 09:17:31 -07009
10S = "${WORKDIR}/git"
11PV = "0.1+git${SRCPV}"
12
13DEPENDS = "boost phosphor-ipmi-host systemd microsoft-gsl"
14
15inherit cmake obmc-phosphor-ipmiprovider-symlink
16
17EXTRA_OECMAKE="-DENABLE_TEST=0 -DYOCTO=1"
18
19LIBRARY_NAMES = "libsensorcommands.so"
20LIBRARY_NAMES += "libzstoragecommands.so"
21LIBRARY_NAMES += "liboemcmds.so"
22
23HOSTIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
24NETIPMI_PROVIDER_LIBRARY += "${LIBRARY_NAMES}"
25
26FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
27FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
28FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
29FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV}"
Richard Marian Thomaiyar40ce4062018-11-21 19:21:07 +053030
31do_install_append(){
32 install -d ${D}${includedir}/intel-ipmi-oem
33 install -m 0644 -D ${S}/include/*.hpp ${D}${includedir}/intel-ipmi-oem
34}