blob: 7d6b9f737c897190be084739fadf56a2f003814f [file] [log] [blame]
Patrick Venture7ebe0262018-03-30 11:23:16 -07001SUMMARY = "Phosphor OpenBMC Post Code Daemon"
2DESCRIPTION = "Phosphor OpenBMC Post Code Daemon"
3PR = "r1"
4
5inherit autotools pkgconfig
6inherit obmc-phosphor-systemd
7
8DEPENDS += "autoconf-archive-native"
9DEPENDS += "sdbusplus"
Kun Yi41d3e4d2018-09-12 11:01:33 -070010DEPENDS += "sdeventplus"
Patrick Venture7ebe0262018-03-30 11:23:16 -070011DEPENDS += "phosphor-dbus-interfaces"
12DEPENDS += "systemd"
13
Kun Yi41d3e4d2018-09-12 11:01:33 -070014RDEPENDS_${PN} += "sdbusplus sdeventplus phosphor-dbus-interfaces"
Patrick Venture7ebe0262018-03-30 11:23:16 -070015
Benjamin Fair89e86cd2018-06-29 13:00:14 -070016SNOOP_DEVICE ?= "aspeed-lpc-snoop0"
17POST_CODE_BYTES ?= "1"
18
19SERVICE_FILE = "lpcsnoop.service"
20SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}"
21SYSTEMD_SUBSTITUTIONS += "SNOOP_DEVICE:${SNOOP_DEVICE}:${SERVICE_FILE}"
22SYSTEMD_SUBSTITUTIONS += "POST_CODE_BYTES:${POST_CODE_BYTES}:${SERVICE_FILE}"
Patrick Venture7ebe0262018-03-30 11:23:16 -070023
24require ${PN}.inc
25
26S = "${WORKDIR}/git"
27