Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL" |
| 2 | DESCRIPTION = "This module offers some high level convenience functions for accessing \ |
| 3 | web pages on SSL servers (for symmetry, same API is offered for \ |
| 4 | accessing http servers, too), a sslcat() function for writing your own \ |
| 5 | clients, and finally access to the SSL api of SSLeay/OpenSSL package \ |
| 6 | so you can write servers or clients for more complicated applications." |
| 7 | HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/" |
| 8 | SECTION = "libs" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e" |
| 12 | |
| 13 | DEPENDS = "openssl zlib openssl-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} += "\ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | libssl \ |
| 16 | libcrypto \ |
| 17 | perl-module-carp \ |
| 18 | perl-module-errno \ |
| 19 | perl-module-extutils-makemaker \ |
| 20 | perl-module-mime-base64 \ |
| 21 | perl-module-socket \ |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 22 | perl-module-autoloader \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | zlib \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \ |
| 27 | file://no-exec-on-configure.patch \ |
| 28 | file://run-ptest \ |
| 29 | " |
| 30 | SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69" |
| 31 | SRC_URI[sha256sum] = "9d8188b9fb1cae3bd791979c20554925d5e94a138d00414f1a6814549927b0c8" |
| 32 | |
| 33 | S = "${WORKDIR}/Net-SSLeay-${PV}" |
| 34 | |
| 35 | inherit cpan ptest |
| 36 | |
| 37 | do_configure() { |
| 38 | export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}" |
| 39 | cpan_do_configure |
| 40 | } |
| 41 | |
| 42 | do_install_ptest() { |
| 43 | cp -r ${B}/t ${D}${PTEST_PATH} |
| 44 | } |
| 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 47 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 48 | RDEPENDS:${PN}-ptest = " perl" |