blob: ded11d8cd2c092f8808afb036d01987b2997ad65 [file] [log] [blame]
Brad Bishop93fb5352015-09-09 03:59:20 +00001# Common code for dbus applications using c.
Brad Bishop93fb5352015-09-09 03:59:20 +00002inherit obmc-phosphor-systemd
Brad Bishop93fb5352015-09-09 03:59:20 +00003
4DEPENDS += "glib-2.0"
Brad Bishop09494ec2015-10-18 22:21:04 -04005
6INSTALL_NAME ?= "${PN}"
7BIN_NAME ?= "${INSTALL_NAME}"
Brad Bishop93fb5352015-09-09 03:59:20 +00008
9do_install_append() {
10 # install the binary
11 install -d ${D}${sbindir}
Brad Bishop09494ec2015-10-18 22:21:04 -040012 install -m 0755 ${S}/${BIN_NAME} ${D}${sbindir}/${INSTALL_NAME}
Brad Bishop93fb5352015-09-09 03:59:20 +000013}