Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Open-source monitoring solution for your IT infrastructure" |
| 2 | DESCRIPTION = "\ |
| 3 | ZABBIX is software that monitors numerous parameters of a network and the \ |
| 4 | health and integrity of servers. ZABBIX uses a flexible notification \ |
| 5 | mechanism that allows users to configure e-mail based alerts for virtually \ |
| 6 | any event. This allows a fast reaction to server problems. ZABBIX offers \ |
| 7 | excellent reporting and data visualisation features based on the stored \ |
| 8 | data. This makes ZABBIX ideal for capacity planning. \ |
| 9 | \ |
| 10 | ZABBIX supports both polling and trapping. All ZABBIX reports and \ |
| 11 | statistics, as well as configuration parameters are accessed through a \ |
| 12 | web-based front end. A web-based front end ensures that the status of \ |
| 13 | your network and the health of your servers can be assessed from any \ |
| 14 | location. Properly configured, ZABBIX can play an important role in \ |
| 15 | monitoring IT infrastructure. This is equally true for small \ |
| 16 | organisations with a few servers and for large companies with a \ |
| 17 | multitude of servers." |
| 18 | HOMEPAGE = "http://www.zabbix.com/" |
| 19 | SECTION = "Applications/Internet" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 20 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e" |
| 22 | DEPENDS = "libevent libpcre openldap virtual/libiconv zlib" |
| 23 | |
| 24 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 25 | |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 26 | SRC_URI = "https://cdn.zabbix.com/zabbix/sources/stable/5.2/${BPN}-${PV}.tar.gz \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 27 | file://0001-Fix-configure.ac.patch \ |
| 28 | file://zabbix-agent.service \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | " |
| 30 | |
Andrew Geissler | e34f896 | 2021-04-15 15:53:51 -0500 | [diff] [blame] | 31 | SRC_URI[md5sum] = "31dab3535a1fa212f5724902727f6d4d" |
| 32 | SRC_URI[sha256sum] = "76cb704f2a04fbc87bb3eff44fa71339c355d467f7bbd8fb53f8927c760e1680" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | |
| 34 | inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd |
| 35 | |
| 36 | SYSTEMD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | SYSTEMD_SERVICE:${PN} = "zabbix-agent.service" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | SYSTEMD_AUTO_ENABLE = "enable" |
| 39 | |
| 40 | USERADD_PACKAGES = "${PN}" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | GROUPADD_PARAM:${PN} = "-r zabbix" |
| 42 | USERADD_PARAM:${PN} = "-r -g zabbix -d /var/lib/zabbix \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 43 | -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \ |
| 44 | " |
| 45 | |
| 46 | KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}" |
| 47 | |
| 48 | EXTRA_OECONF = " \ |
| 49 | --enable-dependency-tracking \ |
| 50 | --enable-agent \ |
| 51 | --enable-ipv6 \ |
| 52 | --with-net-snmp \ |
| 53 | --with-ldap=${STAGING_EXECPREFIXDIR} \ |
| 54 | --with-unixodbc \ |
| 55 | --with-ssh2 \ |
| 56 | --with-sqlite3 \ |
| 57 | --with-zlib \ |
| 58 | --with-libpthread \ |
| 59 | --with-libevent \ |
Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 60 | --with-libpcre=${STAGING_EXECPREFIXDIR} \ |
| 61 | --with-iconv=${STAGING_EXECPREFIXDIR} \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 62 | " |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 63 | CFLAGS:append = " -lldap -llber -pthread" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 64 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 65 | do_configure:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 66 | export KERNEL_VERSION="${KERNEL_VERSION}" |
| 67 | } |
| 68 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 69 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 70 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then |
| 71 | install -d ${D}${systemd_unitdir}/system |
| 72 | install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/ |
| 73 | sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service |
| 74 | fi |
| 75 | } |
| 76 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 77 | FILES:${PN} += "${libdir}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 78 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 79 | RDEPENDS:${PN} = "logrotate" |