blob: 4e318e52f46ba8e11890a82d64c868856595ed62 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Python interface to libarchive"
2DESCRIPTION = "A Python interface to libarchive. It uses the standard ctypes module to \
3 dynamically load and access the C library."
4HOMEPAGE = "https://github.com/Changaco/python-libarchive-c"
5LICENSE = "CC0-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=bcab380227a83bc147350b40a81e6ffc"
7
8PYPI_PACKAGE = "libarchive-c"
9
10inherit pypi setuptools3
11
Patrick Williams44b3caf2024-04-12 16:51:14 -050012SRC_URI[sha256sum] = "7bcce24ea6c0fa3bc62468476c6d2f6264156db2f04878a372027c10615a2721"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14RDEPENDS:${PN} += "\
15 libarchive \
Patrick Williams73bd93f2024-02-20 08:07:48 -060016 python3-ctypes \
17 python3-mmap \
18 python3-logging \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019"
20
21BBCLASSEXTEND = "native"