Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters" |
| 2 | HOMEPAGE = "http://sourceforge.net/projects/hdparm/" |
| 3 | DESCRIPTION = "hdparm is a Linux shell utility for viewing \ |
| 4 | and manipulating various IDE drive and driver parameters." |
| 5 | SECTION = "console/utils" |
| 6 | |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 7 | LICENSE = "BSD-2-Clause & GPLv2 & hdparm" |
| 8 | LICENSE:${PN} = "BSD-2-Clause & hdparm" |
| 9 | LICENSE:${PN}-dbg = "BSD-2-Clause & hdparm" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 10 | LICENSE:wiper = "GPLv2" |
Andrew Geissler | 5199d83 | 2021-09-24 16:47:35 -0500 | [diff] [blame] | 11 | NO_GENERIC_LICENSE[hdparm] = "LICENSE.TXT" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | |
| 13 | LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=495d03e50dc6c89d6a30107ab0df5b03 \ |
| 14 | file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \ |
| 15 | file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \ |
| 16 | file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09" |
| 17 | |
| 18 | |
| 19 | PACKAGES =+ "wiper" |
| 20 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | FILES:wiper = "${bindir}/wiper.sh" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:wiper = "bash gawk coreutils" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | |
| 25 | SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz \ |
| 26 | file://wiper.sh-fix-stat-path.patch \ |
| 27 | " |
| 28 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 29 | SRC_URI[sha256sum] = "2c0f9d75cdbeda928a25a128cd3d0b7120445ec0910c0b29d4c1038ed1be777f" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 30 | |
| 31 | EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"' |
| 32 | |
| 33 | inherit update-alternatives |
| 34 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 35 | ALTERNATIVE:${PN} = "hdparm" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 36 | ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm" |
| 37 | ALTERNATIVE_PRIORITY = "100" |
| 38 | |
| 39 | do_install () { |
| 40 | install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir} |
| 41 | oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install |
| 42 | cp ${S}/wiper/wiper.sh ${D}/${bindir} |
| 43 | } |