blob: 41155ef620b858b8cb0d655d561d74d1d7b7ccdb [file] [log] [blame]
Yong Li33170c32019-01-03 11:41:48 +08001SUMMARY = "Intel DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the Intel YAML"
3PR = "r1"
4PV = "1.0+git${SRCPV}"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Patrick Williams5181f432020-03-31 16:43:15 -050011inherit python3native
Yong Li33170c32019-01-03 11:41:48 +080012inherit phosphor-dbus-yaml
13
14DEPENDS += "autoconf-archive-native"
Patrick Williams5181f432020-03-31 16:43:15 -050015DEPENDS += "${PYTHON_PN}-sdbus++-native"
Yong Li33170c32019-01-03 11:41:48 +080016
Patrick Williamsbb99d222022-01-24 15:55:09 -060017SRC_URI = "git://github.com/openbmc/intel-dbus-interfaces;branch=master;protocol=https"
Andrew Geissler63603d02022-10-11 17:50:48 -050018SRCREV = "603a528495c4e67d8468a5f2ac921026f71575c9"
Yong Li33170c32019-01-03 11:41:48 +080019
Yong Li33170c32019-01-03 11:41:48 +080020PACKAGECONFIG ??= "libintel_dbus"
21PACKAGECONFIG[libintel_dbus] = " \
22 --enable-libintel_dbus, \
23 --disable-libintel_dbus, \
24 systemd sdbusplus, \
Patrick Williams5181f432020-03-31 16:43:15 -050025 libsystemd \
Yong Li33170c32019-01-03 11:41:48 +080026 "
27
Jae Hyun Yoo24e16a22021-08-06 10:55:59 -070028PACKAGECONFIG:remove:class-native = "libintel_dbus"
29PACKAGECONFIG:remove:class-nativesdk = "libintel_dbus"
Yong Li33170c32019-01-03 11:41:48 +080030
Patrick Williams5181f432020-03-31 16:43:15 -050031BBCLASSEXTEND += "native nativesdk"