Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "An implementation of JSON Schema validation for Python" |
| 2 | HOMEPAGE = "https://github.com/Julian/jsonschema" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \ |
| 5 | file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af" |
| 6 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "25203dbebd62a1179f810f14339f7a638baaf279b5cc3b738a58c3744af56d65" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 8 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 9 | inherit pypi python_hatchling |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 11 | DEPENDS += "${PYTHON_PN}-hatch-vcs-native" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 12 | |
| 13 | PACKAGECONFIG ??= "format" |
| 14 | PACKAGECONFIG[format] = ",,,\ |
| 15 | ${PYTHON_PN}-idna \ |
| 16 | ${PYTHON_PN}-jsonpointer \ |
| 17 | ${PYTHON_PN}-webcolors \ |
| 18 | ${PYTHON_PN}-rfc3987 \ |
| 19 | ${PYTHON_PN}-strict-rfc3339 \ |
| 20 | " |
| 21 | PACKAGECONFIG[nongpl] = ",,,\ |
| 22 | ${PYTHON_PN}-idna \ |
| 23 | ${PYTHON_PN}-jsonpointer \ |
| 24 | ${PYTHON_PN}-webcolors \ |
| 25 | ${PYTHON_PN}-rfc3986-validator \ |
| 26 | ${PYTHON_PN}-rfc3339-validator \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS:${PN} += " \ |
| 30 | ${PYTHON_PN}-attrs \ |
| 31 | ${PYTHON_PN}-core \ |
| 32 | ${PYTHON_PN}-datetime \ |
| 33 | ${PYTHON_PN}-importlib-metadata \ |
| 34 | ${PYTHON_PN}-io \ |
| 35 | ${PYTHON_PN}-json \ |
| 36 | ${PYTHON_PN}-netclient \ |
| 37 | ${PYTHON_PN}-numbers \ |
| 38 | ${PYTHON_PN}-pkgutil \ |
| 39 | ${PYTHON_PN}-pprint \ |
| 40 | ${PYTHON_PN}-pyrsistent \ |
| 41 | ${PYTHON_PN}-shell \ |
| 42 | ${PYTHON_PN}-six \ |
| 43 | ${PYTHON_PN}-unittest \ |
| 44 | ${PYTHON_PN}-setuptools-scm \ |
| 45 | ${PYTHON_PN}-zipp \ |
| 46 | " |
| 47 | |
| 48 | BBCLASSEXTEND = "native nativesdk" |