Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenGL / OpenGL ES Reference Compiler" |
| 2 | DESCRIPTION = "Glslang is the official reference compiler front end for the \ |
| 3 | OpenGL ES and OpenGL shading languages. It implements a strict interpretation \ |
| 4 | of the specifications for these languages. It is open and free for anyone to use, \ |
| 5 | either from a command line or programmatically." |
| 6 | SECTION = "graphics" |
| 7 | HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler" |
| 8 | LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3" |
| 10 | |
Patrick Williams | 520786c | 2023-06-25 16:20:36 -0500 | [diff] [blame] | 11 | SRCREV = "d1517d64cfca91f573af1bf7341dc3a5113349c0" |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame] | 12 | SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \ |
| 13 | file://0001-generate-glslang-pkg-config.patch \ |
| 14 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | PE = "1" |
Andrew Geissler | 028142b | 2023-05-05 11:29:21 -0500 | [diff] [blame] | 16 | # These recipes need to be updated in lockstep with each other: |
| 17 | # glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools |
| 18 | # The tags versions should always be sdk-x.y.z, as this is what |
| 19 | # upstream considers a release. |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 20 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit cmake python3native |
| 24 | |
| 25 | EXTRA_OECMAKE = " \ |
| 26 | -DCMAKE_BUILD_TYPE=Release \ |
| 27 | -DBUILD_SHARED_LIBS=ON \ |
| 28 | -DENABLE_PCH=OFF \ |
| 29 | -DENABLE_CTEST=OFF \ |
| 30 | -DBUILD_EXTERNAL=OFF \ |
| 31 | " |
| 32 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 33 | BBCLASSEXTEND = "native nativesdk" |