blob: 6e9c666d46d7c3f89babd28d6fc71d24e58926de [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
10
Patrick Williams520786c2023-06-25 16:20:36 -050011SRCREV = "d1517d64cfca91f573af1bf7341dc3a5113349c0"
Patrick Williams864cc432023-02-09 14:54:44 -060012SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \
13 file://0001-generate-glslang-pkg-config.patch \
14 "
Andrew Geissler517393d2023-01-13 08:55:19 -060015PE = "1"
Andrew Geissler028142b2023-05-05 11:29:21 -050016# These recipes need to be updated in lockstep with each other:
17# glslang, vulkan-headers, vulkan-loader, vulkan-tools, spirv-headers, spirv-tools
18# The tags versions should always be sdk-x.y.z, as this is what
19# upstream considers a release.
Andrew Geissler517393d2023-01-13 08:55:19 -060020UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
21S = "${WORKDIR}/git"
22
23inherit cmake python3native
24
25EXTRA_OECMAKE = " \
26 -DCMAKE_BUILD_TYPE=Release \
27 -DBUILD_SHARED_LIBS=ON \
28 -DENABLE_PCH=OFF \
29 -DENABLE_CTEST=OFF \
30 -DBUILD_EXTERNAL=OFF \
31"
32
Andrew Geissler517393d2023-01-13 08:55:19 -060033BBCLASSEXTEND = "native nativesdk"