blob: 0d447c4915887c046a927a288c5c67ff90bbf820 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "a fast C/C++ compiler cache"
2DESCRIPTION = "ccache is a compiler cache. It speeds up recompilation \
3by caching the result of previous compilations and detecting when the \
4same compilation is being done again. Supported languages are C, C\+\+, \
5Objective-C and Objective-C++."
6HOMEPAGE = "http://ccache.samba.org"
7SECTION = "devel"
8
9LICENSE = "GPL-3.0-or-later"
Patrick Williams39653562024-03-01 08:54:02 -060010LIC_FILES_CHKSUM = "file://LICENSE.adoc;md5=9896d6f0aee4d89b9e5ff0afaae0af06"
Andrew Geissler517393d2023-01-13 08:55:19 -060011
12DEPENDS = "zstd"
13
14SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BP}.tar.gz \
15 file://0001-xxhash.h-Fix-build-with-gcc-12.patch \
16 "
Patrick Williams39653562024-03-01 08:54:02 -060017SRC_URI[sha256sum] = "12834ecaaaf2db069dda1d1d991f91c19e3274cc04a471af5b64195def17e90f"
Andrew Geissler517393d2023-01-13 08:55:19 -060018
19inherit cmake github-releases
20
21PATCHTOOL = "patch"
22
23BBCLASSEXTEND = "native nativesdk"
24
25PACKAGECONFIG[docs] = "-DENABLE_DOCUMENTATION=ON,-DENABLE_DOCUMENTATION=OFF,asciidoc"
26PACKAGECONFIG[redis] = "-DREDIS_STORAGE_BACKEND=ON,-DREDIS_STORAGE_BACKEND=OFF,hiredis"