blob: bd69e16a062a614e7de3d5e5826889ff8b7c67ee [file] [log] [blame]
Mike Garrett4eb108b2021-08-27 15:51:09 -05001LICENSE = "CLOSED"
2LIC_FILES_CHKSUM = ""
3
4# TODO: Manually copy the U-Boot signing key and customer-key-block here:
5HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files"
6
7inherit deploy
8
9do_deploy () {
10 install -d ${DEPLOYDIR}
11
12 # Copy in the bootblock
13 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin
14
15 # Copy in files from the files subdirectory
16 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section
17
18 # Copy in the U-Boot signing key
19 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem
20
21 # Copy in the customer keyblock
22 install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block
23}
24
25addtask deploy before do_build after do_compile
26