blob: 04a022af4ffadd7f02b3bbe7684079776b5b93aa [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
2DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
3system state and activity from a running Linux instance, then save, \
4filter and analyze."
5HOMEPAGE = "http://www.sysdig.org/"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006LICENSE = "Apache-2.0 & (MIT | GPL-2.0)"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05008
9inherit cmake pkgconfig
10
Andrew Geissler82c905d2020-04-13 13:39:40 -050011#OECMAKE_GENERATOR = "Unix Makefiles"
12JIT ?= "jit"
13JIT_mipsarchn32 = ""
14JIT_mipsarchn64 = ""
15JIT_riscv64 = ""
16JIT_riscv32 = ""
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
Andrew Geissler82c905d2020-04-13 13:39:40 -050018DEPENDS += "lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp tbb jq openssl elfutils protobuf protobuf-native jq-native"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050019RDEPENDS_${PN} = "bash"
20
Andrew Geissler82c905d2020-04-13 13:39:40 -050021SRC_URI = "git://github.com/draios/sysdig.git;branch=dev \
22 file://0001-fix-build-with-LuaJIT-2.1-betas.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050023 file://0001-Fix-build-with-musl-backtrace-APIs-are-glibc-specifi.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 file://fix-uint64-const.patch \
25 file://aarch64.patch \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050027SRCREV = "8daeef8da752c5f07f439391bc20c5948eb11470"
28PV = "0.26.6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050029
30S = "${WORKDIR}/git"
31
Andrew Geissler82c905d2020-04-13 13:39:40 -050032EXTRA_OECMAKE = "\
33 -DBUILD_DRIVER=OFF \
34 -DUSE_BUNDLED_DEPS=OFF \
35 -DUSE_BUNDLED_B64=ON \
36 -DCREATE_TEST_TARGETS=OFF \
37 -DDIR_ETC=${sysconfdir} \
38 -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \
39 -DLUA_LIBRARY=libluajit-5.1.so \
40"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050041
42FILES_${PN} += " \
43 ${DIR_ETC}/* \
Patrick Williamsddad1a12017-02-23 20:36:32 -060044 ${datadir}/zsh/* \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050045 ${prefix}/src/* \
46"
Andrew Geissler82c905d2020-04-13 13:39:40 -050047# Use getaddrinfo_a is a GNU extension in libsinsp
48# It should be fixed in sysdig, until then disable
49# on musl
50# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
51COMPATIBLE_HOST_libc-musl = "null"
52COMPATIBLE_HOST_mips = "null"
53COMPATIBLE_HOST_riscv64 = "null"
54COMPATIBLE_HOST_riscv32 = "null"