Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Automatically give your module the ability to have plugins" |
| 2 | DESCRIPTION = "Provides a simple but, hopefully, extensible way of \ |
| 3 | having 'plugins' for your module. Obviously this isn't going to be the \ |
| 4 | be all and end all of solutions but it works for me.\ |
| 5 | \ |
| 6 | Essentially all it does is export a method into your namespace that \ |
| 7 | looks through a search path for .pm files and turn those into class \ |
| 8 | names.\ |
| 9 | \ |
| 10 | Optionally it instantiates those classes for you." |
| 11 | SECTION = "libs" |
| 12 | |
| 13 | AUTHOR = "Simon Wistow <simon@thegestalt.org>" |
| 14 | HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable" |
| 15 | |
| 16 | LICENSE = "Artistic-1.0 | GPL-1.0+" |
| 17 | LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086" |
| 18 | |
| 19 | SRCNAME = "Module-Pluggable" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 20 | SRC_URI = "${CPAN_MIRROR}/authors/id/S/SI/SIMONW/${SRCNAME}-${PV}.tar.gz" |
| 21 | SRC_URI[md5sum] = "87ce2971662efd0b69a81bb4dc9ea76c" |
| 22 | SRC_URI[sha256sum] = "b3f2ad45e4fd10b3fb90d912d78d8b795ab295480db56dc64e86b9fa75c5a6df" |
| 23 | |
| 24 | PR = "r1" |
| 25 | |
| 26 | UPSTREAM_CHECK_REGEX = "Module\-Pluggable\-(?P<pver>(\d+\.\d+))" |
| 27 | UPSTREAM_CHECK_URI = "https://metacpan.org/release/${SRCNAME}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 28 | |
| 29 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 30 | |
| 31 | inherit cpan |
| 32 | |
| 33 | RDEPENDS_${PN} = " perl-module-base \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 34 | perl-module-deprecate \ |
| 35 | perl-module-file-basename \ |
| 36 | perl-module-file-find \ |
| 37 | perl-module-file-spec \ |
| 38 | perl-module-file-spec-functions \ |
| 39 | perl-module-if \ |
| 40 | perl-module-test-more \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 41 | " |
| 42 | |
| 43 | BBCLASSEXTEND = "native" |
| 44 | |