blob: d843eb038cb503c29686dc2456899f1de88ac4c3 [file] [log] [blame]
Andrew Geissler4873add2020-11-02 18:44:49 -06001require boost-${PV}.inc
2
3SUMMARY = "Portable Boost.Jam build tool for boost"
4SECTION = "devel"
5
6inherit native
7
8SRC_URI += "file://0001-Build-debug-version-of-bjam.patch \
9 file://0001-build.sh-use-DNDEBUG-also-in-debug-builds.patch \
10 "
11
12do_compile() {
13 ./bootstrap.sh --with-toolset=gcc
14}
15
16do_install() {
17 install -d ${D}${bindir}/
18 # install unstripped version for bjam
19 install -c -m 755 b2 ${D}${bindir}/bjam
20}