blob: d25600645e4f6926fb3b25dda73185e85a3066dd [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "HTTP based time synchronization tool"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08002DESCRIPTION = "The HTTP Time Protocol (HTP) is used to synchronize a computer's time with\
3 web servers as reference time source. This program can be used instead\
4 ntpdate or similar, in networks that has a firewall blocking the NTP port.\
5 Htpdate will synchronize the computer time to Greenwich Mean Time (GMT),\
6 using the timestamps from HTTP headers found in web servers response (the\
7 HEAD method will be used to get the information).\
8 Htpdate works through proxy servers. Accuracy of htpdate will be usually\
9 within 0.5 seconds (better with multiple servers).\
10"
Patrick Williams03907ee2022-05-01 06:28:52 -050011HOMEPAGE = "https://github.com/twekkel/htpdate"
12BUGTRACKER = "https://github.com/twekkel/htpdate/issues"
Andrew Geissler9aee5002022-03-30 16:27:02 +000013LICENSE = "GPL-2.0-or-later"
Patrick Williams03907ee2022-05-01 06:28:52 -050014LIC_FILES_CHKSUM = "file://htpdate.c;beginline=26;endline=30;md5=2b6cdb94bd5349646d7e33f9f501eef7"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015
Patrick Williams03907ee2022-05-01 06:28:52 -050016SRC_URI = "http://www.vervest.org/htp/archive/c/htpdate-${PV}.tar.gz"
17SRC_URI[sha256sum] = "744f9200cfd3b008a5516c5eb6da727af532255a329126a7b8f49a5623985642"
18
19TARGET_CC_ARCH += "${LDFLAGS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21do_configure () {
22 :
23}
24
25do_compile () {
26 oe_runmake
27}
28
29do_install () {
30 oe_runmake install 'INSTALL=install' 'STRIP=echo' 'DESTDIR=${D}'
31}