blob: 2deaea268f67226fb303a2689682dbdaab23e997 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Open-source monitoring solution for your IT infrastructure"
2DESCRIPTION = "\
3ZABBIX is software that monitors numerous parameters of a network and the \
4health and integrity of servers. ZABBIX uses a flexible notification \
5mechanism that allows users to configure e-mail based alerts for virtually \
6any event. This allows a fast reaction to server problems. ZABBIX offers \
7excellent reporting and data visualisation features based on the stored \
8data. This makes ZABBIX ideal for capacity planning. \
9\
10ZABBIX supports both polling and trapping. All ZABBIX reports and \
11statistics, as well as configuration parameters are accessed through a \
12web-based front end. A web-based front end ensures that the status of \
13your network and the health of your servers can be assessed from any \
14location. Properly configured, ZABBIX can play an important role in \
15monitoring IT infrastructure. This is equally true for small \
16organisations with a few servers and for large companies with a \
17multitude of servers."
18HOMEPAGE = "http://www.zabbix.com/"
19SECTION = "Applications/Internet"
Andrew Geissler9aee5002022-03-30 16:27:02 +000020LICENSE = "GPL-2.0-or-later"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021LIC_FILES_CHKSUM = "file://COPYING;md5=300e938ad303147fede2294ed78fe02e"
22DEPENDS = "libevent libpcre openldap virtual/libiconv zlib"
23
24PACKAGE_ARCH = "${MACHINE_ARCH}"
25
Andrew Geisslerd5838332022-05-27 11:33:10 -050026SRC_URI = "https://cdn.zabbix.com/zabbix/sources/stable/6.0/${BPN}-${PV}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027 file://0001-Fix-configure.ac.patch \
28 file://zabbix-agent.service \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029"
30
Andrew Geissler78b72792022-06-14 06:47:25 -050031SRC_URI[sha256sum] = "3eeb7063efc5dad56f84dfdcf9aeb781044be712e11e83f66d043da55f33bdc2"
Andrew Geissler82c905d2020-04-13 13:39:40 -050032
33inherit autotools-brokensep linux-kernel-base pkgconfig systemd useradd
34
35SYSTEMD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050036SYSTEMD_SERVICE:${PN} = "zabbix-agent.service"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037SYSTEMD_AUTO_ENABLE = "enable"
38
39USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050040GROUPADD_PARAM:${PN} = "-r zabbix"
41USERADD_PARAM:${PN} = "-r -g zabbix -d /var/lib/zabbix \
Andrew Geissler82c905d2020-04-13 13:39:40 -050042 -s /sbin/nologin -c \"Zabbix Monitoring System\" zabbix \
43"
44
45KERNEL_VERSION = "${@get_kernelversion_headers('${STAGING_KERNEL_DIR}')}"
46
47EXTRA_OECONF = " \
48 --enable-dependency-tracking \
49 --enable-agent \
50 --enable-ipv6 \
51 --with-net-snmp \
52 --with-ldap=${STAGING_EXECPREFIXDIR} \
53 --with-unixodbc \
54 --with-ssh2 \
55 --with-sqlite3 \
56 --with-zlib \
57 --with-libpthread \
58 --with-libevent \
Andrew Geissler32b11992021-03-31 13:37:05 -050059 --with-libpcre=${STAGING_EXECPREFIXDIR} \
60 --with-iconv=${STAGING_EXECPREFIXDIR} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050061"
Patrick Williams213cb262021-08-07 19:21:33 -050062CFLAGS:append = " -lldap -llber -pthread"
Andrew Geissler82c905d2020-04-13 13:39:40 -050063
Patrick Williams213cb262021-08-07 19:21:33 -050064do_configure:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050065 export KERNEL_VERSION="${KERNEL_VERSION}"
66}
67
Patrick Williams213cb262021-08-07 19:21:33 -050068do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050069 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
70 install -d ${D}${systemd_unitdir}/system
71 install -m 0644 ${WORKDIR}/zabbix-agent.service ${D}${systemd_unitdir}/system/
72 sed -i -e 's#@SBINDIR@#${sbindir}#g' ${D}${systemd_unitdir}/system/zabbix-agent.service
73 fi
74}
75
Patrick Williams213cb262021-08-07 19:21:33 -050076FILES:${PN} += "${libdir}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050077
Patrick Williams213cb262021-08-07 19:21:33 -050078RDEPENDS:${PN} = "logrotate"