blob: 34f3136de9ca80a6554ae124596d20da215b75d8 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "\
2IPC::Run allows you run and interact with child processes \
3using files, pipes, and pseudo-ttys. Both system()-style and scripted \
4usages are supported and may be mixed. Likewise, functional and OO API \
5styles are both supported and may be mixed."
6HOMEPAGE = "https://metacpan.org/release/IPC-Run"
7SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009LIC_FILES_CHKSUM = "file://LICENSE;md5=0ebd37caf53781e8b7223e6b99b63f4e"
10DEPENDS = "perl"
11
Andrew Geissler595f6302022-01-24 19:11:47 +000012SRC_URI = "git://github.com/toddr/IPC-Run.git;branch=master;protocol=https"
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050013SRCREV = "af435a1635ef9e48a84adc3230099e7ecf20c79d"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15S = "${WORKDIR}/git"
16
17inherit cpan
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21do_compile() {
22 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
23 cpan_do_compile
24}