Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "This is the io_uring library, liburing." |
| 2 | DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \ |
| 3 | instances, and also a simplified interface for applications that don't need \ |
| 4 | (or want) to deal with the full kernel side implementation." |
| 5 | HOMEPAGE = "https://github.com/axboe/liburing" |
| 6 | BUGTRACKER = "https://github.com/axboe/liburing/issues" |
| 7 | SECTION = "libs" |
| 8 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | LICENSE = "LGPL-2.1-only | MIT" |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 10 | LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 12 | SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch " |
| 14 | SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch " |
Andrew Geissler | 615f2f1 | 2022-07-15 14:00:58 -0500 | [diff] [blame] | 15 | SRCREV = "dda4848a9911120a903bef6284fb88286f4464c9" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | DEPENDS:append:libc-musl = " libucontext" |
| 20 | XCFLAGS = "-pthread" |
| 21 | XCFLAGS:append:libc-musl = " -lucontext" |
| 22 | |
| 23 | EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'" |
| 24 | do_configure() { |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 25 | ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir} |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 26 | } |
| 27 | do_install () { |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 28 | oe_runmake install DESTDIR=${D} |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 29 | } |