blob: d90cdb4839970fd64f4cedc9753d9864bb421d1b [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# This variable is set to True if gobject-introspection-data is in
2# DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise.
3#
4# It should be used in recipes to determine whether introspection data should be built,
5# so that qemu use can be avoided when necessary.
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006GI_DATA_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'gobject-introspection-data', \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007 bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}"
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05008
9do_compile:prepend() {
10 # This prevents g-ir-scanner from writing cache data to $HOME
11 export GI_SCANNER_DISABLE_CACHE=1
12}