blob: c162f5d93424358e7c7bd63d884528025aca6853 [file] [log] [blame]
Patrick Williams213cb262021-08-07 19:21:33 -05001SUMMARY:${PN}-ptest ?= "${SUMMARY} - Package test files"
2DESCRIPTION:${PN}-ptest ?= "${DESCRIPTION} \
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003This package contains a test directory ${PTEST_PATH} for package test purposes."
4
Brad Bishop6e60e8b2018-02-01 10:27:11 -05005PTEST_PATH ?= "${libdir}/${BPN}/ptest"
Brad Bishop19323692019-04-05 15:28:33 -04006PTEST_BUILD_HOST_FILES ?= "Makefile"
7PTEST_BUILD_HOST_PATTERN ?= ""
Andrew Geissler615f2f12022-07-15 14:00:58 -05008PTEST_PARALLEL_MAKE ?= "${PARALLEL_MAKE}"
9PTEST_PARALLEL_MAKEINST ?= "${PARALLEL_MAKEINST}"
10EXTRA_OEMAKE:prepend:task-compile-ptest-base = "${PTEST_PARALLEL_MAKE} "
11EXTRA_OEMAKE:prepend:task-install-ptest-base = "${PTEST_PARALLEL_MAKEINST} "
Brad Bishop19323692019-04-05 15:28:33 -040012
Patrick Williams213cb262021-08-07 19:21:33 -050013FILES:${PN}-ptest += "${PTEST_PATH}"
14SECTION:${PN}-ptest = "devel"
15ALLOW_EMPTY:${PN}-ptest = "1"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016PTEST_ENABLED = "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', '1', '0', d)}"
Patrick Williams213cb262021-08-07 19:21:33 -050017PTEST_ENABLED:class-native = ""
18PTEST_ENABLED:class-nativesdk = ""
19PTEST_ENABLED:class-cross-canadian = ""
20RDEPENDS:${PN}-ptest += "${PN}"
21RDEPENDS:${PN}-ptest:class-native = ""
22RDEPENDS:${PN}-ptest:class-nativesdk = ""
23RRECOMMENDS:${PN}-ptest += "ptest-runner"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
25PACKAGES =+ "${@bb.utils.contains('PTEST_ENABLED', '1', '${PN}-ptest', '', d)}"
26
William A. Kennington IIIac69b482021-06-02 12:28:27 -070027require conf/distro/include/ptest-packagelists.inc
28
Patrick Williamsc124f4f2015-09-15 14:41:29 -050029do_configure_ptest() {
30 :
31}
32
33do_configure_ptest_base() {
34 do_configure_ptest
35}
36
37do_compile_ptest() {
38 :
39}
40
41do_compile_ptest_base() {
42 do_compile_ptest
43}
44
45do_install_ptest() {
46 :
47}
48
49do_install_ptest_base() {
50 if [ -f ${WORKDIR}/run-ptest ]; then
51 install -D ${WORKDIR}/run-ptest ${D}${PTEST_PATH}/run-ptest
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052 fi
Patrick Williamsf1e5d692016-03-30 15:21:19 -050053 if grep -q install-ptest: Makefile; then
54 oe_runmake DESTDIR=${D}${PTEST_PATH} install-ptest
55 fi
56 do_install_ptest
57 chown -R root:root ${D}${PTEST_PATH}
Brad Bishop19323692019-04-05 15:28:33 -040058
59 # Strip build host paths from any installed Makefile
60 for filename in ${PTEST_BUILD_HOST_FILES}; do
61 for installed_ptest_file in $(find ${D}${PTEST_PATH} -type f -name $filename); do
62 bbnote "Stripping host paths from: $installed_ptest_file"
63 sed -e 's#${HOSTTOOLS_DIR}/*##g' \
64 -e 's#${WORKDIR}/*=#.=#g' \
65 -e 's#${WORKDIR}/*##g' \
66 -i $installed_ptest_file
67 if [ -n "${PTEST_BUILD_HOST_PATTERN}" ]; then
68 sed -E '/${PTEST_BUILD_HOST_PATTERN}/d' \
69 -i $installed_ptest_file
70 fi
71 done
72 done
Patrick Williamsc124f4f2015-09-15 14:41:29 -050073}
74
Brad Bishopc342db32019-05-15 21:57:59 -040075PTEST_BINDIR_PKGD_PATH = "${PKGD}${PTEST_PATH}/bin"
76
77# This function needs to run after apply_update_alternative_renames because the
78# aforementioned function will update the ALTERNATIVE_LINK_NAME flag. Append is
79# used here to make this function to run as late as possible.
Patrick Williams213cb262021-08-07 19:21:33 -050080PACKAGE_PREPROCESS_FUNCS:append = "${@bb.utils.contains('PTEST_BINDIR', '1', \
Brad Bishopc342db32019-05-15 21:57:59 -040081 bb.utils.contains('PTEST_ENABLED', '1', ' ptest_update_alternatives', '', d), '', d)}"
82
83python ptest_update_alternatives() {
84 """
85 This function will generate the symlinks in the PTEST_BINDIR_PKGD_PATH
86 to match the renamed binaries by update-alternatives.
87 """
88
89 if not bb.data.inherits_class('update-alternatives', d) \
90 or not update_alternatives_enabled(d):
91 return
92
93 bb.note("Generating symlinks for ptest")
94 bin_paths = { d.getVar("bindir"), d.getVar("base_bindir"),
95 d.getVar("sbindir"), d.getVar("base_sbindir") }
96 ptest_bindir = d.getVar("PTEST_BINDIR_PKGD_PATH")
97 os.mkdir(ptest_bindir)
98 for pkg in (d.getVar('PACKAGES') or "").split():
99 alternatives = update_alternatives_alt_targets(d, pkg)
100 for alt_name, alt_link, alt_target, _ in alternatives:
101 # Some alternatives are for man pages,
102 # check if the alternative is in PATH
103 if os.path.dirname(alt_link) in bin_paths:
104 os.symlink(alt_target, os.path.join(ptest_bindir, alt_name))
105}
106
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500107do_configure_ptest_base[dirs] = "${B}"
108do_compile_ptest_base[dirs] = "${B}"
109do_install_ptest_base[dirs] = "${B}"
110do_install_ptest_base[cleandirs] = "${D}${PTEST_PATH}"
111
112addtask configure_ptest_base after do_configure before do_compile
113addtask compile_ptest_base after do_compile before do_install
114addtask install_ptest_base after do_install before do_package do_populate_sysroot
115
116python () {
117 if not bb.data.inherits_class('native', d) and not bb.data.inherits_class('cross', d):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500118 d.setVarFlag('do_install_ptest_base', 'fakeroot', '1')
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300119 d.setVarFlag('do_install_ptest_base', 'umask', '022')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500120
121 # Remove all '*ptest_base' tasks when ptest is not enabled
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500122 if not(d.getVar('PTEST_ENABLED') == "1"):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123 for i in ['do_configure_ptest_base', 'do_compile_ptest_base', 'do_install_ptest_base']:
124 bb.build.deltask(i, d)
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500125}
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700126
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500127QARECIPETEST[missing-ptest] = "package_qa_check_missing_ptest"
128def package_qa_check_missing_ptest(pn, d, messages):
William A. Kennington IIIac69b482021-06-02 12:28:27 -0700129 # This checks that ptest package is actually included
130 # in standard oe-core ptest images - only for oe-core recipes
131 if not 'meta/recipes' in d.getVar('FILE') or not(d.getVar('PTEST_ENABLED') == "1"):
132 return
133
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500134 enabled_ptests = " ".join([d.getVar('PTESTS_FAST'), d.getVar('PTESTS_SLOW'), d.getVar('PTESTS_PROBLEMS')]).split()
135 if (pn + "-ptest").replace(d.getVar('MLPREFIX'), '') not in enabled_ptests:
Andrew Geisslereff27472021-10-29 15:35:00 -0500136 oe.qa.handle_error("missing-ptest", "supports ptests but is not included in oe-core's ptest-packagelists.inc", d)