blob: 39349b60267b7d8315931b109f6d1b37082d5b8a [file] [log] [blame]
Patrick Williams03907ee2022-05-01 06:28:52 -05001SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.org/project/pip"
3SECTION = "devel/python"
4LICENSE = "MIT & Apache-2.0 & MPL-2.0 & LGPL-2.1-only & BSD-3-Clause & PSF-2.0 & BSD-2-Clause"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.txt;md5=63ec52baf95163b597008bb46db68030 \
7 file://src/pip/_vendor/cachecontrol/LICENSE.txt;md5=6572692148079ebbbd800be4b9f36c6d \
8 file://src/pip/_vendor/certifi/LICENSE;md5=67da0714c3f9471067b729eca6c9fbe8 \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05009 file://src/pip/_vendor/chardet/LICENSE;md5=4fbd65380cdd255951079008b364516c \
Patrick Williams03907ee2022-05-01 06:28:52 -050010 file://src/pip/_vendor/colorama/LICENSE.txt;md5=b4936429a56a652b84c5c01280dcaa26 \
11 file://src/pip/_vendor/distlib/LICENSE.txt;md5=f6a11430d5cd6e2cd3832ee94f22ddfc \
Andrew Geisslerd5838332022-05-27 11:33:10 -050012 file://src/pip/_vendor/distro/LICENSE;md5=d2794c0df5b907fdace235a619d80314 \
Patrick Williams03907ee2022-05-01 06:28:52 -050013 file://src/pip/_vendor/idna/LICENSE.md;md5=239668a7c6066d9e0c5382e9c8c6c0e1 \
14 file://src/pip/_vendor/msgpack/COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751 \
15 file://src/pip/_vendor/packaging/LICENSE;md5=faadaedca9251a90b205c9167578ce91 \
16 file://src/pip/_vendor/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
17 file://src/pip/_vendor/pep517/LICENSE;md5=aad69c93f605003e3342b174d9b0708c \
18 file://src/pip/_vendor/pkg_resources/LICENSE;md5=9a33897f1bca1160d7aad3835152e158 \
19 file://src/pip/_vendor/platformdirs/LICENSE.txt;md5=282c970bb844954c8535dd6e9733db7f \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050020 file://src/pip/_vendor/pygments/LICENSE;md5=36a13c90514e2899f1eba7f41c3ee592 \
Patrick Williams03907ee2022-05-01 06:28:52 -050021 file://src/pip/_vendor/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \
22 file://src/pip/_vendor/requests/LICENSE;md5=34400b68072d710fecd0a2940a0d1658 \
23 file://src/pip/_vendor/resolvelib/LICENSE;md5=78e1c0248051c32a38a7f820c30bd7a5 \
24 file://src/pip/_vendor/rich/LICENSE;md5=b5f0b94fbc94f5ad9ae4efcf8a778303 \
25 file://src/pip/_vendor/six.LICENSE;md5=43cfc9e4ac0e377acfb9b76f56b8415d \
26 file://src/pip/_vendor/tenacity/LICENSE;md5=175792518e4ac015ab6696d16c4f607e \
27 file://src/pip/_vendor/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \
28 file://src/pip/_vendor/typing_extensions.LICENSE;md5=64fc2b30b67d0a8423c250e0386ed72f \
29 file://src/pip/_vendor/urllib3/LICENSE.txt;md5=c2823cb995439c984fd62a973d79815c \
30 file://src/pip/_vendor/webencodings/LICENSE;md5=81fb24cd7823cce23b69f721993dce4d \
31"
32
33inherit pypi python_setuptools_build_meta
34
Patrick Williams03907ee2022-05-01 06:28:52 -050035SRC_URI += "file://no_shebang_mangling.patch"
36SRC_URI += "file://reproducible.patch"
37
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050038SRC_URI[sha256sum] = "50516e47a2b79e77446f0d05649f0d53772c192571486236b1905492bfc24bac"
Patrick Williams03907ee2022-05-01 06:28:52 -050039
40do_install:append() {
41 rm -f ${D}/${bindir}/pip
42}
43
44RDEPENDS:${PN} = "\
45 python3-compile \
46 python3-io \
47 python3-html \
48 python3-json \
49 python3-multiprocessing \
50 python3-netserver \
51 python3-setuptools \
52 python3-unixadmin \
53 python3-xmlrpc \
54 python3-pickle \
Andrew Geissler78b72792022-06-14 06:47:25 -050055 python3-distutils \
56 python3-image \
Patrick Williams03907ee2022-05-01 06:28:52 -050057"
58
59BBCLASSEXTEND = "native nativesdk"
60
61# This used to use the bootstrap install which didn't compile. Until we bump the
62# tmpdir version we can't compile the native otherwise the sysroot unpack fails
63INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"