blob: 60ca2ab2827543a822dc0209aeaca83bc8d52210 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "A text-based user interface plugin of dnf for user to manage packages. "
2LICENSE = "GPLv2"
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6SRC_URI = "git://github.com/ubinux/dnf-plugin-tui.git;branch=master "
William A. Kennington III49e95662021-09-15 16:19:36 -07007SRCREV = "b0d80b7129f1d84cc563a4098d869e7420bcf4bc"
8PV = "1.3"
Brad Bishop26bdd442019-08-16 17:08:17 -04009
Patrick Williams213cb262021-08-07 19:21:33 -050010SRC_URI:append:class-target = " file://oe-remote.repo.sample"
Brad Bishop26bdd442019-08-16 17:08:17 -040011
12inherit distutils3-base
13
14S = "${WORKDIR}/git"
15
Patrick Williams213cb262021-08-07 19:21:33 -050016do_install:append() {
Brad Bishop90ca7472019-08-20 09:15:15 -040017 install -d ${D}${datadir}/dnf
18 install -m 0755 ${S}/samples/* ${D}${datadir}/dnf
19 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
20 install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
21 for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do
22 install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins
23 done
Brad Bishop26bdd442019-08-16 17:08:17 -040024}
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append:class-target() {
Brad Bishop90ca7472019-08-20 09:15:15 -040027 install -d ${D}${sysconfdir}/yum.repos.d
28 install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d
Brad Bishop26bdd442019-08-16 17:08:17 -040029}
30
Patrick Williams213cb262021-08-07 19:21:33 -050031FILES:${PN} += "${datadir}/dnf"
Brad Bishop26bdd442019-08-16 17:08:17 -040032
Patrick Williams213cb262021-08-07 19:21:33 -050033RDEPENDS:${PN} += " \
Brad Bishop90ca7472019-08-20 09:15:15 -040034 bash \
35 dnf \
36 libnewt-python \
37"
Brad Bishop26bdd442019-08-16 17:08:17 -040038
39BBCLASSEXTEND = "nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050040PNBLACKLIST[dnf-plugin-tui] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build correctly without package_rpm in PACKAGE_CLASSES', d)}"