Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Generates traces of I/O traffic on block devices" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "blktrace is a block layer IO tracing mechanism which provides \ |
| 3 | detailed information about request queue operations up to user space. There \ |
| 4 | are three major components: a kernel component, a utility to record the i/o \ |
| 5 | trace information for the kernel to user space, and utilities to analyse and \ |
| 6 | view the trace information." |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 7 | HOMEPAGE = "http://brick.kernel.dk/snaps/" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | LICENSE = "GPLv2" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" |
| 10 | |
| 11 | DEPENDS = "libaio" |
| 12 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 13 | SRCREV = "366d30b9cdb20345c5d064af850d686da79b89eb" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 15 | PV = "1.3.0+git${SRCPV}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 16 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame] | 17 | SRC_URI = "git://git.kernel.dk/blktrace.git" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | EXTRA_OEMAKE = "\ |
| 22 | 'CC=${CC}' \ |
| 23 | 'CFLAGS=${CFLAGS}' \ |
| 24 | 'LDFLAGS=${LDFLAGS}' \ |
| 25 | " |
| 26 | |
| 27 | # There are a few parallel issues: |
| 28 | # 1) ../rbtree.o: error adding symbols: Invalid operation |
| 29 | # collect2: error: ld returned 1 exit status |
| 30 | # Makefile:42: recipe for target 'btt' failed |
| 31 | # 2) git/blkiomon.c:216: undefined reference to `rb_insert_color' |
| 32 | # collect2: error: ld returned 1 exit status |
| 33 | # Makefile:27: recipe for target 'blkparse' failed |
| 34 | # 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab' |
| 35 | # 4) btreplay.o: file not recognized: File truncated |
| 36 | # collect2: error: ld returned 1 exit status |
| 37 | # btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory |
| 38 | PARALLEL_MAKE = "" |
| 39 | |
| 40 | do_install() { |
| 41 | oe_runmake ARCH="${ARCH}" prefix=${prefix} \ |
| 42 | mandir=${mandir} DESTDIR=${D} install |
| 43 | } |
| 44 | |