blob: 7ccc022b931bc1b595050f288e4dda928ddfca5f [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Generates traces of I/O traffic on block devices"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "blktrace is a block layer IO tracing mechanism which provides \
3detailed information about request queue operations up to user space. There \
4are three major components: a kernel component, a utility to record the i/o \
5trace information for the kernel to user space, and utilities to analyse and \
6view the trace information."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007HOMEPAGE = "http://brick.kernel.dk/snaps/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
10
11DEPENDS = "libaio"
12
Brad Bishop316dfdd2018-06-25 12:45:53 -040013SRCREV = "cca113f2fe0759b91fd6a0e10fdcda2c28f18a7e"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
Brad Bishop316dfdd2018-06-25 12:45:53 -040015PV = "1.2.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
17SRC_URI = "git://git.kernel.dk/blktrace.git \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050018 file://ldflags.patch \
Brad Bishopbba38f32018-08-23 16:11:46 +080019 file://CVE-2018-10689.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 file://make-btt-scripts-python3-ready.patch \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050021"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050022
23S = "${WORKDIR}/git"
24
25EXTRA_OEMAKE = "\
26 'CC=${CC}' \
27 'CFLAGS=${CFLAGS}' \
28 'LDFLAGS=${LDFLAGS}' \
29"
30
31# There are a few parallel issues:
32# 1) ../rbtree.o: error adding symbols: Invalid operation
33# collect2: error: ld returned 1 exit status
34# Makefile:42: recipe for target 'btt' failed
35# 2) git/blkiomon.c:216: undefined reference to `rb_insert_color'
36# collect2: error: ld returned 1 exit status
37# Makefile:27: recipe for target 'blkparse' failed
38# 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab'
39# 4) btreplay.o: file not recognized: File truncated
40# collect2: error: ld returned 1 exit status
41# btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory
42PARALLEL_MAKE = ""
43
44do_install() {
45 oe_runmake ARCH="${ARCH}" prefix=${prefix} \
46 mandir=${mandir} DESTDIR=${D} install
47}
48