blob: fea9ce1b5d14f9e59b6121e98209a4344e0944cd [file] [log] [blame]
George Hungf089ba12020-05-20 17:22:25 +08001PR = "r1"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
4
George Hungf089ba12020-05-20 17:22:25 +08005inherit systemd
6inherit obmc-phosphor-systemd
7
George Hungf089ba12020-05-20 17:22:25 +08008SRC_URI = " file://phosphor-ipmi-flash-bmc-verify.service \
9 file://bmc-verify.sh \
10 file://config-bmc.json \
11 "
12
Brandon Kim1e427092021-08-10 15:46:03 -070013FILES:${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
George Hungf089ba12020-05-20 17:22:25 +080014
Brandon Kimcf406822021-07-30 16:19:14 -070015PROVIDES += "virtual/bmc-update"
Brandon Kim1e427092021-08-10 15:46:03 -070016RPROVIDES:${PN} += "virtual/bmc-update"
Brandon Kimcf406822021-07-30 16:19:14 -070017
George Hungf089ba12020-05-20 17:22:25 +080018DEPENDS += "systemd"
19DEPENDS += "phosphor-ipmi-flash"
Brandon Kim1e427092021-08-10 15:46:03 -070020RDEPENDS:${PN} = "bash"
George Hungf089ba12020-05-20 17:22:25 +080021
22do_install() {
23 install -d ${D}${bindir}
24 install -m 0755 ${WORKDIR}/bmc-verify.sh ${D}${bindir}/
25
26 install -d ${D}${systemd_system_unitdir}
27 install -m 0644 ${WORKDIR}/phosphor-ipmi-flash-bmc-verify.service ${D}${systemd_system_unitdir}
28
29 install -d ${D}${datadir}/phosphor-ipmi-flash
30 install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
31}
32
33
34SYSTEMD_PACKAGES = "${PN}"
Brandon Kim1e427092021-08-10 15:46:03 -070035SYSTEMD_SERVICE:${PN} = "phosphor-ipmi-flash-bmc-verify.service"