blob: 451670e64f0e4660e9ce3b4f18c652ee6441f3b4 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "LGPL-2.0-or-later"
Andrew Geisslereff27472021-10-29 15:35:00 -05003LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36"
4
5GNOMEBASEBUILDCLASS = "autotools"
6
7inherit gnomebase gsettings gobject-introspection gsettings gtk-doc vala gettext features_check
8
Andrew Geissler78b72792022-06-14 06:47:25 -05009ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
Andrew Geisslereff27472021-10-29 15:35:00 -050010
11DEPENDS = "glib-2.0"
12
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI += "file://0001-Update-to-rest-1.0.patch"
Patrick Williams58776372022-04-13 09:07:35 -050014SRC_URI[archive.sha256sum] = "381d5d4106f435b6f87786aa049be784774e15996adcc02789807afc87ea7342"
Andrew Geisslereff27472021-10-29 15:35:00 -050015
16# backend is required for gnome-control-center
17PACKAGECONFIG = "backend other"
18
Andrew Geissler595f6302022-01-24 19:11:47 +000019PACKAGECONFIG[backend] = "--enable-backend,--disable-backend,gtk+3 webkitgtk libsoup-2.4 json-glib libsecret rest libxml2"
Andrew Geisslereff27472021-10-29 15:35:00 -050020PACKAGECONFIG[krb5] = "--enable-kerberos, --disable-kerberos , krb5 gcr"
21
22# no extra dependencies!
23PACKAGECONFIG[other] = " \
24 --enable-facebook --enable-foursquare --enable-exchange --enable-flickr --enable-google --enable-imap-smtp --enable-owncloud --enable-windows-live,\
25 --disable-facebook --disable-foursquare --disable-exchange --disable-flickr --disable-google --disable-imap-smtp --disable-owncloud --disable-windows-live, \
26"
27
28FILES:${PN} += " \
29 ${datadir}/dbus-1 \
30 ${libdir}/goa-1.0/web-extensions/*.so \
31"
32
33# looked into pkg-config file: it is not a bug - they mean it
34FILES:${PN}-dev += "${libdir}/goa-1.0/include"