blob: 876efe663b16dccde740da89176c519d06a3b177 [file] [log] [blame]
Jason M. Bills4a8312c2022-11-02 08:25:11 -07001PACKAGECONFIG:append:s6q = " sync-mac"
Jerry Wan77938922022-01-28 09:57:37 +08002
3FILES:${PN}:append:s6q = " ${datadir}/network/config.json"
4
5do_install:append:s6q() {
6 install -d ${D}${datadir}/network/
7 if ${@bb.utils.contains('MACHINE_FEATURES', 'bonding', 'true', 'false', d)};
8 then
9 echo '{"bond0":"bmc","eth0":"bmc","eth1":"bmc"}' \
10 > ${D}${datadir}/network/config.json
11 else
12 echo '{"eth0":"bmc"}' > ${D}${datadir}/network/config.json
13 fi
14}