blob: 071be345d26dd0047b419272916de71d0e592051 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Video Acceleration (VA) API for Linux"
2DESCRIPTION = "Video Acceleration API (VA API) is a library (libVA) \
3and API specification which enables and provides access to graphics \
4hardware (GPU) acceleration for video processing on Linux and UNIX \
5based operating systems. Accelerated processing includes video \
6decoding, video encoding, subpicture blending and rendering. The \
7specification was originally designed by Intel for its GMA (Graphics \
8Media Accelerator) series of GPU hardware, the API is however not \
9limited to GPUs or Intel specific hardware, as other hardware and \
10manufacturers can also freely use this API for hardware accelerated \
11video decoding."
12
13HOMEPAGE = "https://01.org/linuxmedia/vaapi"
14BUGTRACKER = "https://github.com/intel/libva/issues"
15
16SECTION = "x11"
17LICENSE = "MIT"
18LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f"
19
20SRC_URI = "https://github.com/intel/${BPN}/releases/download/${PV}/${BP}.tar.bz2"
21SRC_URI[md5sum] = "aef13eb48e01a47d1416d97462a22a11"
22SRC_URI[sha256sum] = "6c57eb642d828af2411aa38f55dc10111e8c98976dbab8fd62e48629401eaea5"
23
24UPSTREAM_CHECK_URI = "https://github.com/intel/libva/releases"
25
Andrew Geissler4b740dc2020-05-05 08:54:39 -050026DEPENDS = "libdrm"
Andrew Geissler82c905d2020-04-13 13:39:40 -050027
28inherit meson pkgconfig features_check
29
Andrew Geissler4b740dc2020-05-05 08:54:39 -050030PACKAGECONFIG ??= " \
31 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \
32 ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \
33"
Andrew Geissler82c905d2020-04-13 13:39:40 -050034
Andrew Geissler4b740dc2020-05-05 08:54:39 -050035PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes"
36PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa"
37
38PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland"
Andrew Geissler82c905d2020-04-13 13:39:40 -050039
40PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland"
41
42RDEPENDS_${PN}-x11 =+ "${PN}"
43RDEPENDS_${PN}-glx =+ "${PN}-x11"
44
45FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}"
46FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}"
47FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}"