blob: 01682a46d4db7e0458e5162d2767ee7a0317db60 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The module provides handy URL class for url parsing and changing"
2HOMEPAGE = "https://github.com/aio-libs/yarl/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b"
5
Andrew Geissler4b7c1152020-11-30 19:55:29 -06006SRC_URI[sha256sum] = "8a9066529240171b68893d60dca86a763eae2139dd42f42106b03cf4b426bf10"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI += " \
9 file://run-ptest \
10"
11
12PYPI_PACKAGE = "yarl"
13
14inherit pypi ptest setuptools3
15
16RDEPENDS_${PN} = "\
17 ${PYTHON_PN}-multidict \
18 ${PYTHON_PN}-idna \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
28}