blob: 13467189b4240c7519f5f381428a13f4a56e54c3 [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=9674cc803c5d71306941e6e8b5c002f2"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://dhcpcd.service \
17 file://dhcpcd@.service \
18 "
19
20SRC_URI[sha256sum] = "fcb2d19672d445bbfd38678fdee4f556ef967a3ea6bd81092d10545df2cb9666"
21
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050022inherit pkgconfig autotools-brokensep systemd useradd
Andrew Geisslerc9f78652020-09-18 14:11:35 -050023
24SYSTEMD_SERVICE_${PN} = "dhcpcd.service"
25
26PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27
28PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
Andrew Geissler4c19ea12020-10-27 13:52:24 -050030# ntp conflicts with chrony
31PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
32PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
33PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050034
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050035EXTRA_OECONF = "--enable-ipv4 \
36 --dbdir=${localstatedir}/lib/${BPN} \
37 --runstatedir=/run \
Andrew Geissler4c19ea12020-10-27 13:52:24 -050038 --enable-privsep \
39 --privsepuser=dhcpcd \
40 --with-hooks \
41 --with-eghooks \
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050042 "
43
44USERADD_PACKAGES = "${PN}"
45USERADD_PARAM_${PN} = "--system -d ${localstatedir}/lib/${BPN} -M -s /bin/false -U dhcpcd"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050046
47do_install_append () {
48 # install systemd unit files
49 install -d ${D}${systemd_unitdir}/system
50 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_unitdir}/system
Andrew Geisslerc3d88e42020-10-02 09:45:00 -050051
52 chmod 700 ${D}${localstatedir}/lib/${BPN}
53 chown dhcpcd:dhcpcd ${D}${localstatedir}/lib/${BPN}
Andrew Geisslerc9f78652020-09-18 14:11:35 -050054}
55
56FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"