blob: 0befe277e96463e5f0f8faec9726e3c6791d6dfa [file] [log] [blame]
Deepak Kodihallif98bd112017-03-24 07:44:16 -05001SUMMARY = "OpenPOWER OCC controller"
2DESCRIPTION = "Application to contol the OpenPOWER On-Chip-Controller"
3HOMEPAGE = "https://github.com/openbmc/openpower-occ-control"
4PR = "r1"
5
Deepak Kodihalli615bdc12017-04-06 23:50:34 -05006inherit autotools \
7 pkgconfig \
Vishwanatha Subbanna359eee82017-05-04 09:45:29 -05008 obmc-phosphor-dbus-service \
9 pythonnative
Deepak Kodihallif98bd112017-03-24 07:44:16 -050010
11require ${PN}.inc
12
Andrew Geissler4cd9d0a2017-08-15 14:04:51 -050013SRC_URI += "file://occ-active.sh"
14do_install_append() {
15 install -d ${D}${bindir}
16 install -m 0755 ${WORKDIR}/occ-active.sh \
17 ${D}${bindir}/occ-active.sh
18}
19
Vishwanatha Subbanna5f74f132017-07-07 02:55:58 -050020DBUS_SERVICE_${PN} += "org.open_power.OCC.Control.service"
Andrew Geissler4cd9d0a2017-08-15 14:04:51 -050021SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
Deepak Kodihallif98bd112017-03-24 07:44:16 -050022
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +053023DEPENDS += "virtual/${PN}-config-native"
Deepak Kodihallif98bd112017-03-24 07:44:16 -050024DEPENDS += " \
25 sdbusplus \
26 sdbusplus-native \
27 phosphor-logging \
28 openpower-dbus-interfaces \
Vishwanatha Subbanna5f74f132017-07-07 02:55:58 -050029 phosphor-dbus-interfaces \
Deepak Kodihallif98bd112017-03-24 07:44:16 -050030 openpower-dbus-interfaces-native \
31 autoconf-archive-native \
Andrew Geissler4cd9d0a2017-08-15 14:04:51 -050032 obmc-targets \
33 systemd \
Deepak Kodihallif98bd112017-03-24 07:44:16 -050034 "
35
36RDEPENDS_${PN} += " \
37 sdbusplus \
38 phosphor-logging \
39 openpower-dbus-interfaces \
Vishwanatha Subbanna5f74f132017-07-07 02:55:58 -050040 phosphor-dbus-interfaces \
Deepak Kodihallif98bd112017-03-24 07:44:16 -050041 "
42
Vishwanatha Subbannafcf50762017-08-09 15:00:34 +053043EXTRA_OECONF = "YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN}"
Lei YU80caf062017-07-20 15:25:28 +080044EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
45
Andrew Geissler4cd9d0a2017-08-15 14:04:51 -050046# Ensure host stop target requires occ disable service
47OCC_DISABLE_TMPL = "op-occ-disable@.service"
48HOST_STOP_TGTFMT = "obmc-host-stop@{0}.target"
49OCC_DISABLE_INSTFMT = "op-occ-disable@{0}.service"
50HOST_STOP_OCC_DISABLE_FMT = "../${OCC_DISABLE_TMPL}:${HOST_STOP_TGTFMT}.requires/${OCC_DISABLE_INSTFMT}"
51SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_STOP_OCC_DISABLE_FMT', 'OBMC_HOST_INSTANCES')}"
52
Deepak Kodihallif98bd112017-03-24 07:44:16 -050053S = "${WORKDIR}/git"