blob: 4d1eafd537703c8081d53e3d55d77d12ee5390c4 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Brad Bishope1615142020-04-22 14:06:02 -04002
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003PACKAGECONFIG:append:p10bmc = " host-dump-transport-pldm"
4PACKAGECONFIG:append:witherspoon-tacoma = " host-dump-transport-pldm"
Matt Spinlerb9e821a2018-03-29 16:34:38 -05005
Adriana Kobylakb96c7502021-08-06 16:25:30 +00006PACKAGECONFIG:append:p10bmc = " openpower-dumps-extension"
7PACKAGECONFIG:append:witherspoon-tacoma = " openpower-dumps-extension"
Dhruvaraj Subhashchandran21ebf782020-09-24 01:33:00 -05008
Dhruvaraj Subhashchandran26fb25b2022-01-18 07:07:18 -06009SYSTEMD_SERVICE:${PN}-manager:p10bmc += "clear_hostdumps_poweroff.service"
Andrew Geissler4d38aa92023-01-23 16:10:25 -060010SYSTEMD_SERVICE:${PN}-manager:witherspoon-tacoma += "clear_hostdumps_poweroff.service"
Dhruvaraj Subhashchandran26fb25b2022-01-18 07:07:18 -060011
Matt Spinlerb9e821a2018-03-29 16:34:38 -050012install_ibm_plugins() {
Marri Devender Raoce928ac2022-04-08 08:54:38 -050013 install ${S}/tools/dreport.d/ibm.d/plugins.d/* ${D}${dreport_plugin_dir}/
Matt Spinlerb9e821a2018-03-29 16:34:38 -050014}
15
16#Link in the plugins so dreport run them at the appropriate time
17python link_ibm_plugins() {
Marri Devender Raoce928ac2022-04-08 08:54:38 -050018 source = d.getVar('S', True)
19 source_path = os.path.join(source, "tools", "dreport.d", "ibm.d", "plugins.d")
20 op_plugins = os.listdir(source_path)
21 for op_plugin in op_plugins:
22 op_plugin_name = os.path.join(source_path, op_plugin)
23 install_dreport_user_script(op_plugin_name, d)
Matt Spinlerb9e821a2018-03-29 16:34:38 -050024}
25
Chirag Sharma4b5211d2020-09-29 08:18:17 -050026#Install dump header script from dreport/ibm.d to dreport/include.d
27install_dreport_header() {
28 install -d ${D}${dreport_include_dir}
PriyangaRamasamybcbcea82021-03-02 22:49:05 -060029 install -m 0755 ${S}/tools/dreport.d/ibm.d/gendumpheader ${D}${dreport_include_dir}/
Chirag Sharma4b5211d2020-09-29 08:18:17 -050030}
31
32IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
Marri Devender Raoce928ac2022-04-08 08:54:38 -050033IBM_INSTALL_POSTFUNCS:p10bmc += "install_dreport_header"
Chirag Sharma4b5211d2020-09-29 08:18:17 -050034
35do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"