blob: d25adb8cd8faf61a2a12f728eba7769959e7ede6 [file] [log] [blame]
Adriana Kobylakb96c7502021-08-06 16:25:30 +00001FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
Brad Bishope1615142020-04-22 14:06:02 -04002
Adriana Kobylakb96c7502021-08-06 16:25:30 +00003PACKAGECONFIG:append:p10bmc = " host-dump-transport-pldm"
4PACKAGECONFIG:append:witherspoon-tacoma = " host-dump-transport-pldm"
Matt Spinlerb9e821a2018-03-29 16:34:38 -05005
Adriana Kobylakb96c7502021-08-06 16:25:30 +00006PACKAGECONFIG:append:p10bmc = " openpower-dumps-extension"
7PACKAGECONFIG:append:witherspoon-tacoma = " openpower-dumps-extension"
Dhruvaraj Subhashchandran21ebf782020-09-24 01:33:00 -05008
Matt Spinlerb9e821a2018-03-29 16:34:38 -05009install_ibm_plugins() {
Marri Devender Raoce928ac2022-04-08 08:54:38 -050010 install ${S}/tools/dreport.d/ibm.d/plugins.d/* ${D}${dreport_plugin_dir}/
Matt Spinlerb9e821a2018-03-29 16:34:38 -050011}
12
13#Link in the plugins so dreport run them at the appropriate time
14python link_ibm_plugins() {
Marri Devender Raoce928ac2022-04-08 08:54:38 -050015 source = d.getVar('S', True)
16 source_path = os.path.join(source, "tools", "dreport.d", "ibm.d", "plugins.d")
17 op_plugins = os.listdir(source_path)
18 for op_plugin in op_plugins:
19 op_plugin_name = os.path.join(source_path, op_plugin)
20 install_dreport_user_script(op_plugin_name, d)
Matt Spinlerb9e821a2018-03-29 16:34:38 -050021}
22
Chirag Sharma4b5211d2020-09-29 08:18:17 -050023#Install dump header script from dreport/ibm.d to dreport/include.d
24install_dreport_header() {
25 install -d ${D}${dreport_include_dir}
PriyangaRamasamybcbcea82021-03-02 22:49:05 -060026 install -m 0755 ${S}/tools/dreport.d/ibm.d/gendumpheader ${D}${dreport_include_dir}/
Chirag Sharma4b5211d2020-09-29 08:18:17 -050027}
28
29IBM_INSTALL_POSTFUNCS = "install_ibm_plugins link_ibm_plugins"
Marri Devender Raoce928ac2022-04-08 08:54:38 -050030IBM_INSTALL_POSTFUNCS:p10bmc += "install_dreport_header"
Chirag Sharma4b5211d2020-09-29 08:18:17 -050031
32do_install[postfuncs] += "${IBM_INSTALL_POSTFUNCS}"