blob: b68048a50d49b308167dc57fddebdfc2640eab45 [file] [log] [blame]
Rick Altherr4d9fd232016-12-08 12:21:49 -08001DESCRIPTION = "Small image capable of booting a device. The kernel includes \
2the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
3first 'init' program more efficiently."
4
5PACKAGE_INSTALL = "${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL} obmc-phosphor-initfs"
6
7# Do not pollute the initrd image with rootfs features
8IMAGE_FEATURES = ""
9
10export IMAGE_BASENAME = "obmc-phosphor-initramfs"
11IMAGE_LINGUAS = ""
12
13LICENSE = "MIT"
14
15IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
16inherit core-image
17
18IMAGE_ROOTFS_SIZE = "8192"
19IMAGE_ROOTFS_EXTRA_SPACE = "0"
20
21BAD_RECOMMENDATIONS += "busybox-syslog"