blob: 21a8b1aeb25673776ac2b9eb3ee45a6bda1a2495 [file] [log] [blame]
Willy Tu5538c162021-02-10 11:44:57 -08001SUMMARY = "nftables systemd wrapper"
2DESCRIPTION = "nftables systemd wrapper"
3PR = "r1"
4PV = "1.0"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
8
9inherit systemd
10
William A. Kennington IIIc20feb72021-03-08 12:31:30 -080011SRC_URI += " \
12 file://nft-configure.sh \
13 file://nftables.service \
14 "
15
Willy Tu4dd03ca2021-08-06 09:37:35 -070016SYSTEMD_SERVICE:${PN} += "nftables.service"
Willy Tu5538c162021-02-10 11:44:57 -080017
Willy Tu4dd03ca2021-08-06 09:37:35 -070018RDEPENDS:${PN} += " \
William A. Kennington III9b167192021-03-08 11:59:56 -080019 bash \
20 nftables \
21 "
22
Willy Tu5538c162021-02-10 11:44:57 -080023do_install() {
William A. Kennington IIIc20feb72021-03-08 12:31:30 -080024 install -d ${D}${libexecdir}
25 install -m0755 ${WORKDIR}/nft-configure.sh ${D}${libexecdir}/
26
27 install -d ${D}${systemd_system_unitdir}
28 install -m0644 ${WORKDIR}/nftables.service ${D}${systemd_system_unitdir}/
Willy Tu5538c162021-02-10 11:44:57 -080029}