blob: 6c7b6fa8c3979f0c994f8111007407ac760d3c0c [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Audio decoder for MPEG-1 Layer 1/2/3"
2DESCRIPTION = "The core of mpg123 is an MPEG-1 Layer 1/2/3 decoding library, which can be used by other programs. \
3mpg123 also comes with a command-line tool which can playback using ALSA, PulseAudio, OSS, and several other APIs, \
4and also can write the decoded audio to WAV."
5HOMEPAGE = "http://mpg123.de/"
6BUGTRACKER = "http://sourceforge.net/p/mpg123/bugs/"
7SECTION = "multimedia"
8
9LICENSE = "LGPLv2.1"
Brad Bishop316dfdd2018-06-25 12:45:53 -040010LIC_FILES_CHKSUM = "file://COPYING;md5=1e86753638d3cf2512528b99079bc4f3"
11
Brad Bishopc342db32019-05-15 21:57:59 -040012SRC_URI = "https://www.mpg123.de/download/${BP}.tar.bz2 \
13 file://sdl2.patch"
Brad Bishop6dbb3162019-11-25 09:41:34 -050014SRC_URI[md5sum] = "294a6c30546504ec3d0deac2b2ea22be"
15SRC_URI[sha256sum] = "90306848359c793fd43b9906e52201df18775742dc3c81c06ab67a806509890a"
Brad Bishop316dfdd2018-06-25 12:45:53 -040016
Andrew Geissler4ed12e12020-06-05 18:00:41 -050017UPSTREAM_CHECK_REGEX = "mpg123-(?P<pver>\d+(\.\d+)+)\.tar"
18
Brad Bishop316dfdd2018-06-25 12:45:53 -040019inherit autotools pkgconfig
20
21# The options should be mutually exclusive for configuration script.
22# If both alsa and pulseaudio are specified (as in the default distro features)
23# pulseaudio takes precedence.
24PACKAGECONFIG_ALSA = "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
25PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio', '${PACKAGECONFIG_ALSA}', d)}"
26
27PACKAGECONFIG[alsa] = "--with-default-audio=alsa,,alsa-lib"
28PACKAGECONFIG[esd] = ",,esound"
29PACKAGECONFIG[jack] = ",,jack"
30PACKAGECONFIG[openal] = ",,openal-soft"
31PACKAGECONFIG[portaudio] = ",,portaudio-v19"
32PACKAGECONFIG[pulseaudio] = "--with-default-audio=pulse,,pulseaudio"
Brad Bishopc342db32019-05-15 21:57:59 -040033PACKAGECONFIG[sdl] = ",,libsdl2"
Brad Bishop316dfdd2018-06-25 12:45:53 -040034
35# Following are possible sound output modules:
36# alsa arts coreaudio dummy esd jack nas openal os2 oss portaudio pulse sdl sndio sun tinyalsa win32 win32_wasapi
37AUDIOMODS += "${@bb.utils.filter('PACKAGECONFIG', 'alsa esd jack openal portaudio sdl', d)}"
38AUDIOMODS += "${@bb.utils.contains('PACKAGECONFIG', 'pulseaudio', 'pulse', '', d)}"
39
40EXTRA_OECONF = " \
41 --enable-shared \
42 --with-audio='${AUDIOMODS}' \
43 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-cpu=neon', '', d)} \
44 ${@bb.utils.contains('TUNE_FEATURES', 'altivec', '--with-cpu=altivec', '', d)} \
45"
46# Fails to build with thumb-1 (qemuarm)
47#| {standard input}: Assembler messages:
48#| {standard input}:47: Error: selected processor does not support Thumb mode `smull r5,r6,r7,r4'
49#| {standard input}:48: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r5,r5,lsr#24'
50#...
51#| make[3]: *** [equalizer.lo] Error 1
52ARM_INSTRUCTION_SET_armv4 = "arm"
53ARM_INSTRUCTION_SET_armv5 = "arm"