Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A library for bits of crypto UI and parsing etc" |
| 2 | DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \ |
| 3 | accessing key stores. It also provides the viewer for crypto files on the \ |
| 4 | GNOME desktop." |
| 5 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr" |
| 6 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues" |
| 7 | |
| 8 | LICENSE = "GPL-2.0-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 10 | |
| 11 | DEPENDS = "p11-kit glib-2.0 libgcrypt gnupg-native \ |
| 12 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}" |
| 13 | |
| 14 | CACHED_CONFIGUREVARS += "ac_cv_path_GPG='gpg2'" |
| 15 | |
| 16 | CFLAGS += "-D_GNU_SOURCE" |
| 17 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 18 | GTKDOC_MESON_OPTION = "gtk_doc" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 19 | VALA_MESON_OPTION ?= '' |
| 20 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 21 | inherit gnomebase gtk-icon-cache gi-docgen features_check upstream-version-is-even vala gobject-introspection gettext mime mime-xdg |
| 22 | UPSTREAM_CHECK_REGEX = "[^\d\.](?P<pver>3.(?!9\d+)\d+(\.\d+)+)\.tar" |
| 23 | |
| 24 | SRC_URI = "https://download.gnome.org/sources/gcr/3.41/gcr-${PV}.tar.xz;name=archive" |
| 25 | SRC_URI += "file://0001-meson.build-correctly-handle-disabled-ssh_agent-opti.patch" |
| 26 | SRC_URI[archive.sha256sum] = "bb7128a3c2febbfee9c03b90d77d498d0ceb237b0789802d60185c71c4bea24f" |
| 27 | |
| 28 | S = "${WORKDIR}/gcr-${PV}" |
| 29 | |
| 30 | PACKAGECONFIG ??= " \ |
| 31 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 32 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \ |
| 33 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'gtk', '', d)} \ |
| 34 | " |
| 35 | PACKAGECONFIG[gtk] = "-Dgtk=true,-Dgtk=false,gtk+3" |
| 36 | PACKAGECONFIG[ssh_agent] = "-Dssh_agent=true,-Dssh_agent=false,libsecret,openssh" |
| 37 | #'Use systemd socket activation for server programs' |
| 38 | PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd" |
| 39 | |
| 40 | FILES:${PN} += " \ |
| 41 | ${datadir}/dbus-1 \ |
| 42 | ${datadir}/gcr-3 \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 43 | ${datadir}/vala \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 44 | ${systemd_user_unitdir}/gcr-ssh-agent.socket \ |
| 45 | ${systemd_user_unitdir}/gcr-ssh-agent.service \ |
| 46 | " |
| 47 | |
| 48 | # http://errors.yoctoproject.org/Errors/Details/20229/ |
| 49 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 50 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 51 | ARM_INSTRUCTION_SET:armv6 = "arm" |
| 52 | |
| 53 | EXTRA_OEMESON += "--cross-file ${WORKDIR}/meson-${PN}.cross" |
| 54 | do_write_config:append() { |
| 55 | cat >${WORKDIR}/meson-${PN}.cross <<EOF |
| 56 | [binaries] |
| 57 | gpg2 = '${bindir}/gpg2' |
| 58 | ssh-add = '${bindir}/ssh-add' |
| 59 | ssh-agent = '${bindir}/ssh-agent' |
| 60 | EOF |
| 61 | } |