Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "A simple wrapper around optparse for powerful command line utilities." |
| 2 | DESCRIPTION = "\ |
| 3 | Click is a Python package for creating beautiful command line interfaces \ |
| 4 | in a composable way with as little code as necessary. It's the "Command \ |
| 5 | Line Interface Creation Kit". It's highly configurable but comes with \ |
| 6 | sensible defaults out of the box." |
| 7 | HOMEPAGE = "http://click.pocoo.org/" |
| 8 | LICENSE = "BSD-3-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=1fa98232fd645608937a0fdc82e999b8" |
| 10 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame^] | 11 | SRC_URI[sha256sum] = "ca9853ad459e787e2192211578cc907e7594e294c7ccc834310722b41b9ca6de" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 12 | |
| 13 | inherit pypi setuptools3 ptest |
| 14 | |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 15 | SRC_URI += "file://run-ptest" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 16 | |
| 17 | RDEPENDS:${PN}-ptest += " \ |
| 18 | ${PYTHON_PN}-pytest \ |
| 19 | ${PYTHON_PN}-terminal \ |
| 20 | ${PYTHON_PN}-unixadmin \ |
| 21 | " |
| 22 | |
| 23 | do_install_ptest() { |
| 24 | install -d ${D}${PTEST_PATH}/tests |
| 25 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 26 | cp -rf ${S}/setup.cfg ${D}${PTEST_PATH}/ |
| 27 | cp -rf ${S}/docs ${D}${PTEST_PATH}/ |
| 28 | } |
| 29 | |
| 30 | UPSTREAM_CHECK_REGEX = "click/(?P<pver>\d+(\.\d+)+)/" |
| 31 | |
| 32 | CLEANBROKEN = "1" |
| 33 | |
| 34 | RDEPENDS:${PN} += "\ |
| 35 | ${PYTHON_PN}-io \ |
| 36 | ${PYTHON_PN}-threading \ |
| 37 | " |
| 38 | |
| 39 | BBCLASSEXTEND = "native nativesdk" |