blob: 504fe03275824baec5d98afffa187dccc6733191 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Development package for building Applications that use numa"
2HOMEPAGE = "http://oss.sgi.com/projects/libnuma/"
3DESCRIPTION = "Simple NUMA policy support. It consists of a numactl program \
4to run other programs with a specific NUMA policy and a libnuma to do \
5allocations with NUMA policy in applications."
6LICENSE = "GPL-2.0 & LGPL-2.1"
7SECTION = "apps"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008
9inherit autotools-brokensep ptest
10
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011LIC_FILES_CHKSUM = "file://README.md;beginline=19;endline=32;md5=f8ff2391624f28e481299f3f677b21bb"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
Andrew Geisslera2681d92020-10-16 10:17:07 -050013SRCREV = "dd6de072c92c892a86e18c0fd0dfa1ba57a9a05d"
14PV = "2.0.14+git${SRCPV}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015
16SRC_URI = "git://github.com/numactl/numactl \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://Fix-the-test-output-format.patch \
18 file://Makefile \
19 file://run-ptest \
20 file://0001-define-run-test-target.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021"
22
23S = "${WORKDIR}/git"
24
25# ARM does not currently support NUMA
26COMPATIBLE_HOST = "^((?!arm).*)$"
27
Andrew Geisslera2681d92020-10-16 10:17:07 -050028LDFLAGS_append_riscv64 = " -latomic"
29LDFLAGS_append_riscv32 = " -latomic"
30
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031do_install() {
32 oe_runmake DESTDIR=${D} prefix=${D}/usr install
33 #remove the empty man2 directory
34 rm -r ${D}${mandir}/man2
35}
36
37do_compile_ptest() {
38 oe_runmake test
39}
40
41do_install_ptest() {
42 #install tests binaries
43 local test_binaries="distance ftok mbind_mig_pages migrate_pages move_pages \
44 mynode nodemap node-parse pagesize prefered randmap realloc_test \
45 tbitmap tshared"
46
47 [ ! -d ${D}/${PTEST_PATH}/test ] && mkdir -p ${D}/${PTEST_PATH}/test
48 for i in $test_binaries; do
49 install -m 0755 ${B}/test/.libs/$i ${D}${PTEST_PATH}/test
50 done
51
52 local test_scripts="checktopology checkaffinity printcpu regress regress2 \
53 shmtest runltp bind_range"
54 for i in $test_scripts; do
55 install -m 0755 ${B}/test/$i ${D}${PTEST_PATH}/test
56 done
57
58 install -m 0755 ${WORKDIR}/Makefile ${D}${PTEST_PATH}/
59 install -m 0755 ${B}/.libs/numactl ${D}${PTEST_PATH}/
60}
61
62RDEPENDS_${PN}-ptest = "bash"