blob: 5323554ba8f0b11df90ecbd5c513c6887d766034 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "HTML5 (plugin-free) web-based terminal emulator and SSH client"
2LICENSE = "AGPL-3.0"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=834cbc6995db88433db17cdf8953a428"
4HOMEPAGE = "http://liftoffsoftware.com/Products/GateOne"
5
6PV = "1.2+git${SRCPV}"
7SRCREV = "f7a9be46cb90f57459ebd363d24702de0e651034"
8SRC_URI = "git://github.com/liftoff/GateOne.git;branch=master \
9 file://gateone-avahi.service \
10 file://80oe.conf.in \
11 file://gateone.service.in \
12 file://gateone-init.in \
13"
14
15S = "${WORKDIR}/git"
16
17inherit distutils python-dir systemd update-rc.d
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018
19DISTUTILS_INSTALL_ARGS = "--root=${D} \
20 --prefix=${prefix} \
21 --install-lib=${PYTHON_SITEPACKAGES_DIR} \
22 --install-data=${PYTHON_SITEPACKAGES_DIR} \
23 --install-scripts=${bindir} \
24 --skip_init_scripts"
25
26do_install_append() {
27
28 # fix up hardcoded paths
29 for file in gateone.service gateone-init 80oe.conf; do
30 sed -e s:@bindir@:${bindir}:g \
31 -e s:@localstate@:${localstatedir}:g \
32 < ${WORKDIR}/$file.in \
33 > ${WORKDIR}/$file
34 done
Patrick Williamsddad1a12017-02-23 20:36:32 -060035
Patrick Williamsb48b7b42016-08-17 15:04:38 -050036 install -d ${D}${systemd_unitdir}/system
37 install -m 0644 ${WORKDIR}/gateone.service ${D}${systemd_unitdir}/system
38
39 install -d ${D}${sysconfdir}/init.d
40 install -m 0755 ${WORKDIR}/gateone-init ${D}${sysconfdir}/init.d/gateone
Patrick Williamsddad1a12017-02-23 20:36:32 -060041
Patrick Williamsb48b7b42016-08-17 15:04:38 -050042 install -m 0755 -d ${D}${sysconfdir}/avahi/services/
43 install -m 0644 ${WORKDIR}/gateone-avahi.service ${D}${sysconfdir}/avahi/services/
44
45 install -m 0755 -d ${D}${sysconfdir}/gateone/conf.d/
46 install -m 0644 ${WORKDIR}/80oe.conf ${D}${sysconfdir}/gateone/conf.d/80oe.conf
47
48 install -d ${D}${localstatedir}/lib/gateone
49}
50
51FILES_${PN} = "${localstatedir}/lib ${bindir} ${base_libdir} ${sysconfdir} ${PYTHON_SITEPACKAGES_DIR}"
52RDEPENDS_${PN} = "mime-support \
53 openssh-ssh \
54 python-compression \
55 python-contextlib \
56 python-crypt \
57 python-datetime \
58 python-email \
59 python-fcntl \
60 python-futures \
61 python-html \
62 python-imaging \
63 python-io \
64 python-json \
65 python-logging \
66 python-misc \
67 python-multiprocessing \
68 python-netclient \
69 python-pkgutil \
70 python-pyopenssl \
71 python-re \
72 python-readline \
73 python-setuptools \
74 python-shell \
75 python-simplejson \
76 python-subprocess \
77 python-syslog \
78 python-terminal \
79 python-textutils \
80 python-tornado \
81 python-unixadmin \
82 python-xml \
83 python-html5lib \
84 bash \
85"
86
87SYSTEMD_SERVICE_${PN} = "gateone.service"
88INITSCRIPT_NAME = "gateone"