blob: 17417ba5d947d02cf7046916b24afd56521a424b [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# grub-efi.bbclass
2# Copyright (c) 2011, Intel Corporation.
3# All rights reserved.
4#
5# Released under the MIT license (see packages/COPYING)
6
7# Provide grub-efi specific functions for building bootable images.
8
9# External variables
10# ${INITRD} - indicates a list of filesystem images to concatenate and use as an initrd (optional)
11# ${ROOTFS} - indicates a filesystem image to include as the root filesystem (optional)
12# ${GRUB_GFXSERIAL} - set this to 1 to have graphics and serial in the boot menu
13# ${LABELS} - a list of targets for the automatic config
14# ${APPEND} - an override list of append strings for each label
15# ${GRUB_OPTS} - additional options to add to the config, ';' delimited # (optional)
16# ${GRUB_TIMEOUT} - timeout before executing the deault label (optional)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017# ${GRUB_ROOT} - grub's root device.
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19do_bootimg[depends] += "${MLPREFIX}grub-efi:do_deploy"
20do_bootdirectdisk[depends] += "${MLPREFIX}grub-efi:do_deploy"
21
22GRUB_SERIAL ?= "console=ttyS0,115200"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050023GRUB_CFG_VM = "${S}/grub_vm.cfg"
24GRUB_CFG_LIVE = "${S}/grub_live.cfg"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050025GRUB_TIMEOUT ?= "10"
26#FIXME: build this from the machine config
27GRUB_OPTS ?= "serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1"
28
29EFIDIR = "/EFI/BOOT"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050030GRUB_ROOT ?= "${ROOT}"
31APPEND ?= ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050032
33# Need UUID utility code.
34inherit fs-uuid
35
36efi_populate() {
37 # DEST must be the root of the image so that EFIDIR is not
38 # nested under a top level directory.
39 DEST=$1
40
41 install -d ${DEST}${EFIDIR}
42
43 GRUB_IMAGE="bootia32.efi"
44 if [ "${TARGET_ARCH}" = "x86_64" ]; then
45 GRUB_IMAGE="bootx64.efi"
46 fi
47 install -m 0644 ${DEPLOY_DIR_IMAGE}/${GRUB_IMAGE} ${DEST}${EFIDIR}
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048 EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g')
49 printf 'fs0:%s\%s\n' "$EFIPATH" "$GRUB_IMAGE" >${DEST}/startup.nsh
Patrick Williamsc124f4f2015-09-15 14:41:29 -050050
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051 install -m 0644 ${GRUB_CFG} ${DEST}${EFIDIR}/grub.cfg
Patrick Williamsc124f4f2015-09-15 14:41:29 -050052}
53
54efi_iso_populate() {
55 iso_dir=$1
56 efi_populate $iso_dir
57 # Build a EFI directory to create efi.img
58 mkdir -p ${EFIIMGDIR}/${EFIDIR}
59 cp $iso_dir/${EFIDIR}/* ${EFIIMGDIR}${EFIDIR}
60 cp $iso_dir/vmlinuz ${EFIIMGDIR}
Patrick Williamsf1e5d692016-03-30 15:21:19 -050061 EFIPATH=$(echo "${EFIDIR}" | sed 's/\//\\/g')
Patrick Williamsc0f7c042017-02-23 20:41:17 -060062 printf 'fs0:%s\%s\n' "$EFIPATH" "$GRUB_IMAGE" > ${EFIIMGDIR}/startup.nsh
Patrick Williamsc124f4f2015-09-15 14:41:29 -050063 if [ -f "$iso_dir/initrd" ] ; then
64 cp $iso_dir/initrd ${EFIIMGDIR}
65 fi
66}
67
68efi_hddimg_populate() {
69 efi_populate $1
70}
71
72python build_efi_cfg() {
73 import sys
74
75 workdir = d.getVar('WORKDIR', True)
76 if not workdir:
77 bb.error("WORKDIR not defined, unable to package")
78 return
79
80 gfxserial = d.getVar('GRUB_GFXSERIAL', True) or ""
81
82 labels = d.getVar('LABELS', True)
83 if not labels:
84 bb.debug(1, "LABELS not defined, nothing to do")
85 return
86
87 if labels == []:
88 bb.debug(1, "No labels, nothing to do")
89 return
90
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050091 cfile = d.getVar('GRUB_CFG', True)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092 if not cfile:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060093 bb.fatal('Unable to read GRUB_CFG')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050094
95 try:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060096 cfgfile = open(cfile, 'w')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050097 except OSError:
Patrick Williamsc0f7c042017-02-23 20:41:17 -060098 bb.fatal('Unable to open %s' % cfile)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050099
100 cfgfile.write('# Automatically created by OE\n')
101
102 opts = d.getVar('GRUB_OPTS', True)
103 if opts:
104 for opt in opts.split(';'):
105 cfgfile.write('%s\n' % opt)
106
107 cfgfile.write('default=%s\n' % (labels.split()[0]))
108
109 timeout = d.getVar('GRUB_TIMEOUT', True)
110 if timeout:
111 cfgfile.write('timeout=%s\n' % timeout)
112 else:
113 cfgfile.write('timeout=50\n')
114
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500115 root = d.getVar('GRUB_ROOT', True)
116 if not root:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600117 bb.fatal('GRUB_ROOT not defined')
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500118
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500119 if gfxserial == "1":
120 btypes = [ [ " graphics console", "" ],
121 [ " serial console", d.getVar('GRUB_SERIAL', True) or "" ] ]
122 else:
123 btypes = [ [ "", "" ] ]
124
125 for label in labels.split():
126 localdata = d.createCopy()
127
128 overrides = localdata.getVar('OVERRIDES', True)
129 if not overrides:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600130 bb.fatal('OVERRIDES not defined')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500131
132 for btype in btypes:
133 localdata.setVar('OVERRIDES', label + ':' + overrides)
134 bb.data.update_data(localdata)
135
136 cfgfile.write('\nmenuentry \'%s%s\'{\n' % (label, btype[0]))
137 lb = label
138 if label == "install":
139 lb = "install-efi"
140 cfgfile.write('linux /vmlinuz LABEL=%s' % (lb))
141
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500142 cfgfile.write(' %s' % replace_rootfs_uuid(d, root))
143
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 append = localdata.getVar('APPEND', True)
145 initrd = localdata.getVar('INITRD', True)
146
147 if append:
148 append = replace_rootfs_uuid(d, append)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600149 cfgfile.write(' %s' % (append))
150
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500151 cfgfile.write(' %s' % btype[1])
152 cfgfile.write('\n')
153
154 if initrd:
155 cfgfile.write('initrd /initrd')
156 cfgfile.write('\n}\n')
157
158 cfgfile.close()
159}