blob: 508deb29c928decf5bd9162d604ea4360cf46268 [file] [log] [blame]
Brad Bishopbec4ebc2022-08-03 09:55:16 -04001# Image class to write .fvpconf files for use with runfvp. If this is desired
2# then add fvpboot to IMAGE_CLASSES, and set the variables below in your machine
3# configuration as appropriate.
4
5# Name of recipe providing FVP executable. If unset then the executable must be installed on the host.
6FVP_PROVIDER ?= ""
7# Name of FVP executable to run
8FVP_EXE ?= ""
9# Flags for --parameter/-C
10FVP_CONFIG ?= ""
11# Flags for --data
12FVP_DATA ?= ""
13# Flags for --application
14FVP_APPLICATIONS ?= ""
15# Flags to name serial terminals. Flag name is the terminal id (such as
16# terminal_0), value is a human-readable name. If the name is not set
17# then runfvp will hide the terminal.
18FVP_TERMINALS ?= ""
19# What terminal should be considered the primary console
20FVP_CONSOLE ?= ""
21# Flags for console names, as they appear in the FVP output. Flag name is an
22# application-specific id for the console for use in test cases
23FVP_CONSOLES[default] ?= "${FVP_CONSOLE}"
24# Arbitrary extra arguments
25FVP_EXTRA_ARGS ?= ""
Patrick Williams8dd68482022-10-04 07:57:18 -050026# Bitbake variables to pass to the FVP environment
Andrew Geissler517393d2023-01-13 08:55:19 -060027FVP_ENV_PASSTHROUGH ?= "FASTSIM_DISABLE_TA"
28# Disable timing annotation by default
29FASTSIM_DISABLE_TA ?= "1"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040030
31EXTRA_IMAGEDEPENDS += "${FVP_PROVIDER}"
32
Patrick Williams92b42cb2022-09-03 06:53:57 -050033IMAGE_CLASSES += "image-artifact-names"
Brad Bishopbec4ebc2022-08-03 09:55:16 -040034
35IMAGE_POSTPROCESS_COMMAND += "do_write_fvpboot_conf;"
36python do_write_fvpboot_conf() {
37 # Note that currently this JSON file is in development and the format may
38 # change at any point, so it should always be used with a matching runfvp.
39
40 import json, shlex
41
42 if not d.getVar("FVP_EXE"):
43 return
44
45 conffile = os.path.join(d.getVar("IMGDEPLOYDIR"), d.getVar("IMAGE_NAME") + ".fvpconf")
46 conffile_link = os.path.join(d.getVar("IMGDEPLOYDIR"), d.getVar("IMAGE_LINK_NAME") + ".fvpconf")
47
48 data = {}
49 provider = d.getVar("FVP_PROVIDER")
50 if provider:
51 data["provider"] = provider
52 data["fvp-bindir"] = os.path.join(d.getVar("COMPONENTS_DIR"),
53 d.getVar("BUILD_ARCH"),
54 provider,
55 "usr", "bin")
56
57 def getFlags(varname):
58 flags = d.getVarFlags(varname)
59 # For unexplained reasons, getVarFlags() returns None if there are no flags
60 if flags is None:
61 return {}
62 # For other reasons, you can't pass expand=True
63 return {key: d.expand(value) for key, value in flags.items()}
64
65 data["exe"] = d.getVar("FVP_EXE")
66 data["parameters"] = getFlags("FVP_CONFIG")
67 data["data"] = shlex.split(d.getVar("FVP_DATA") or "")
68 data["applications"] = getFlags("FVP_APPLICATIONS")
69 data["consoles"] = getFlags("FVP_CONSOLES")
70 data["terminals"] = getFlags("FVP_TERMINALS")
71 data["args"] = shlex.split(d.getVar("FVP_EXTRA_ARGS") or "")
72
Patrick Williams8dd68482022-10-04 07:57:18 -050073 data["env"] = {}
74 for var in d.getVar("FVP_ENV_PASSTHROUGH").split():
75 data["env"][var] = d.getVar(var)
76
Brad Bishopbec4ebc2022-08-03 09:55:16 -040077 os.makedirs(os.path.dirname(conffile), exist_ok=True)
78 with open(conffile, "wt") as f:
79 json.dump(data, f)
80
81 if conffile_link != conffile:
82 if os.path.lexists(conffile_link):
83 os.remove(conffile_link)
84 os.symlink(os.path.basename(conffile), conffile_link)
85}
86
87def fvpboot_vars(d):
88 vars = ['DEPLOY_DIR_IMAGE', 'IMAGE_NAME', 'IMAGE_LINK_NAME', 'COMPONENTS_DIR', 'BUILD_ARCH']
89 vars.extend((k for k in d.keys() if k.startswith('FVP_')))
90 return " ".join(vars)
91
92do_write_fvpboot_conf[vardeps] += "${@fvpboot_vars(d)}"